Bug 202337 - multimedia/mpv remove youtube-dl optional build dependency
Summary: multimedia/mpv remove youtube-dl optional build dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jan Beich
URL:
Keywords: regression
Depends on:
Blocks: 204216
  Show dependency treegraph
 
Reported: 2015-08-15 00:17 UTC by rozhuk.im
Modified: 2015-11-23 02:21 UTC (History)
3 users (show)

See Also:
cjpm: maintainer-feedback+


Attachments
Patch (1.28 KB, patch)
2015-08-16 22:43 UTC, Carlos J Puga Medina
no flags Details | Diff
Patch (1.08 KB, patch)
2015-08-17 06:05 UTC, Carlos J Puga Medina
no flags Details | Diff
partially backout r386202 (597 bytes, patch)
2015-11-05 11:25 UTC, Jan Beich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rozhuk.im 2015-08-15 00:17:03 UTC
Im setup:
multimedia/mpv
with YTDL option, and youtube-dl + rtmp installed, but
pkg autoremove
remove youtube-dl and rtmp.
Comment 1 Carlos J Puga Medina 2015-08-15 12:59:29 UTC
See pkg-autoremove(8) man page.

You can deinstall multimedia/mpv running the following command:
# cd /usr/ports/multimedia/mpv && make deinstall clean
Comment 2 Carlos J Puga Medina 2015-08-16 22:43:54 UTC
Created attachment 159935 [details]
Patch

Remove www/youtube_dl from mpv config options to avoid pkg-autoremove(8) deinstall it unnecessarily.
Comment 3 Carlos J Puga Medina 2015-08-17 06:05:08 UTC
Created attachment 159943 [details]
Patch
Comment 4 commit-hook freebsd_committer 2015-08-17 20:44:40 UTC
A commit references this bug:

Author: pi
Date: Mon Aug 17 20:44:12 UTC 2015
New revision: 394532
URL: https://svnweb.freebsd.org/changeset/ports/394532

Log:
  multimedia/mpv: remove www/youtube_dl build dependency

  PR:		202337
  Submitted by:	Carlos J Puga Medina <cpm@fbsd.es> (maintainer)

Changes:
  head/multimedia/mpv/Makefile
Comment 5 Kurt Jaeger freebsd_committer 2015-08-17 20:45:41 UTC
Committed, thanks. Build-tested on current.
Comment 6 Jan Beich freebsd_committer 2015-08-17 23:36:35 UTC
Why not use RUN_DEPENDS instead? run-deps are properly registered during install thus won't be affected by pkg-autoremove.

  $ pkg info -xr youtube
  youtube_dl-2015.06.04.1:
          mpv-0.9.2_3,1
Comment 7 Jan Beich freebsd_committer 2015-08-17 23:58:56 UTC
Hmm, ports r386202 changed BUILD_DEPENDS -> RUN_DEPENDS without explaining why and which led to this bug.
Comment 8 Jan Beich freebsd_committer 2015-08-17 23:59:44 UTC
Err, typo: RUN_DEPENDS -> BUILD_DEPENDS.
Comment 9 rozhuk.im 2015-08-19 17:17:24 UTC
(In reply to Carlos J Puga Medina from comment #1)

I dont want to remove mpv!
Some times i run: pkg autoremove
and it breaks mpv+youtube-dl because youtube-dl removed as "unneeded".
Comment 10 rozhuk.im 2015-08-19 17:19:36 UTC
(In reply to Jan Beich from comment #8)

mpv does not depend from youtube-dl? (to build and run)
Ok, i will install youtube-dl by hands.
Comment 11 Carlos J Puga Medina 2015-08-19 17:24:44 UTC
(In reply to rozhuk.im from comment #10)

Yes, it was removed. I prefer that www/youtube_dl be installed separately.
Comment 12 rozhuk.im 2015-08-20 15:04:24 UTC
Ok.
Thanks!
Comment 13 Jan Beich freebsd_committer 2015-11-05 11:03:11 UTC
Reopen as ports r400828 reverted ports r394532 without fixing comment 0 which is a regression since ports r386202.
Comment 14 Jan Beich freebsd_committer 2015-11-05 11:25:31 UTC
Created attachment 162808 [details]
partially backout r386202

Patch per comment 6-8. Re-using existing maintainer-feedback? flag for approval.
Comment 15 commit-hook freebsd_committer 2015-11-21 02:27:09 UTC
A commit references this bug:

Author: jbeich
Date: Sat Nov 21 02:27:02 UTC 2015
New revision: 402130
URL: https://svnweb.freebsd.org/changeset/ports/402130

Log:
  multimedia/mpv: partially backout r386202

  youtube-dl is only used during runtime, so register dependency properly.
  As the port doesn't enforce *where* to find the script rely on PATH.

  PR:		202337
  Approved by:	Carlos J Puga Medina <cpm@fbsd.es> (maintainer)

Changes:
  head/multimedia/mpv/Makefile
Comment 16 commit-hook freebsd_committer 2015-11-23 02:21:54 UTC
A commit references this bug:

Author: junovitch
Date: Mon Nov 23 02:21:09 UTC 2015
New revision: 402254
URL: https://svnweb.freebsd.org/changeset/ports/402254

Log:
  multimedia/mpv: address regressions from r402235 and r402236

  - Remove INSTALLS_ICONS (see r395763 commit message)
  - Set YTDL option as RUN_DEPENDS (see r402130 commit message)

  PR:		202806
  PR:		202337
  PR:             204599
  Reported by:	jbeich
  Approved by:	cpm (implicit from bug 202337 and 202806 approvals)

Changes:
  head/multimedia/mpv/Makefile