Bug 202499 - games/nlarn: Fix build with clang 3.7.0
Summary: games/nlarn: Fix build with clang 3.7.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Dimitry Andric
URL:
Keywords: patch
Depends on:
Blocks: 201377
  Show dependency treegraph
 
Reported: 2015-08-19 22:00 UTC by Dimitry Andric
Modified: 2015-11-13 09:41 UTC (History)
5 users (show)

See Also:
koobs: maintainer-feedback+
antoine: merge-quarterly-


Attachments
Fix uninitialized variables in games/nlarn (1.99 KB, patch)
2015-08-19 22:00 UTC, Dimitry Andric
no flags Details | Diff
Fix uninitialized variables, change maintainer, pet portlint (3.41 KB, patch)
2015-11-06 13:13 UTC, Torsten Zühlsdorff
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitry Andric freebsd_committer 2015-08-19 22:00:44 UTC
Created attachment 160118 [details]
Fix uninitialized variables in games/nlarn

During the exp-run in bug 201377, it was found that games/nlarn gives errors with a recent clang 3.7.0 snapshot:

http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/nlarn-0.7.2.log

This is because there are a few instances in the program where uninitialized variables may be used.  I have tried to fix them in the attached patch.
Comment 1 martin 2015-08-24 08:18:26 UTC
I don't have a FreeBSD machine anymore, and am unlikely to install one in the near future. I forgot I had some ports I maintain.

so I'm afraid I can't say anything meaningful about this, or any other, PR submitted for this port...
Comment 2 Carlo Strub freebsd_committer 2015-09-11 23:48:30 UTC
Would you be willing taking over maintainership of this port?
Comment 3 Dimitry Andric freebsd_committer 2015-10-16 08:18:36 UTC
(In reply to Carlo Strub from comment #2)
> Would you be willing taking over maintainership of this port?

I was only trying to fix clang 3.7.0 import fallout.  I have no particular interest in the port itself.
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2015-10-16 08:56:25 UTC
Dimitry / Carlo,

One of you can assign yourselves the issue and commit given maintainer feedback in comment 1. Please have tested the port with poudriere to confirm it at least builds, ideally runs.

While you're there, please reset MAINTAINER line on the same basis (comment 1)
Comment 5 Torsten Zühlsdorff 2015-10-28 14:06:06 UTC
(In reply to martin from comment #1)

> I don't have a FreeBSD machine anymore, and am unlikely to install 
> one in the near future. I forgot I had some ports I maintain.

At the moment you are the maintainer of 4 ports:
http://portscout.freebsd.org/martin@arp242.net.html

If you do not want to be their maintainer anymore i will take care of them. :)
Comment 6 Torsten Zühlsdorff 2015-11-05 14:12:00 UTC
Hello,

i will be the future maintainer of this port. I applied your patch and can confirm, that the port still builds and runs on my FreeBSD 10.2 amd64.

I also done build test with poudriere which are fine for:

9.3 amd64 + i386
10.1 amd64 + i386
10.2 amd64 + i386
11-current r290334 amd64 + i386

Therefore i would approve the patch and will be happy to see it committed :)

Thank you very much,
Torsten
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-06 07:03:21 UTC
@Torsten, please provide a new patch based on attachment 160118 [details], that also includes a MAINTAINER change.

Someone then needs to assign and commit (Carlo, Dimitry?)
Comment 8 Torsten Zühlsdorff 2015-11-06 13:13:09 UTC
Created attachment 162853 [details]
Fix uninitialized variables, change maintainer, pet portlint

Attached a patch which contains:
- the fixed uninitialized variables patch
- change of the maintainer
- change of existing patches to pet portlint -> i regenerated them with make makepatch

I did an additional poudriere build run and everything is fine with this patch for:

9.3 amd64 + i386
10.1 amd64 + i386
10.2 amd64 + i386
11-current r290334 amd64 + i386
Comment 9 commit-hook freebsd_committer 2015-11-06 19:30:11 UTC
A commit references this bug:

Author: dim
Date: Fri Nov  6 19:29:43 UTC 2015
New revision: 400954
URL: https://svnweb.freebsd.org/changeset/ports/400954

Log:
  ?Fix a number of uninitialized variable warnings in games/nlarn.  Also
  reset the maintainer to Torsten Z?hlsdorff, and bump the port revision.

  PR:		202499
  MFH:		2015Q4

Changes:
  head/games/nlarn/Makefile
  head/games/nlarn/files/patch-Makefile
  head/games/nlarn/files/patch-src-game.c
  head/games/nlarn/files/patch-src-monsters.c
  head/games/nlarn/files/patch-src-player.c
Comment 10 Dimitry Andric freebsd_committer 2015-11-06 19:32:03 UTC
Awaiting permission to merge to the 2015Q4 ports branch.
Comment 11 commit-hook freebsd_committer 2015-11-07 11:33:29 UTC
A commit references this bug:

Author: dim
Date: Sat Nov  7 11:32:54 UTC 2015
New revision: 400979
URL: https://svnweb.freebsd.org/changeset/ports/400979

Log:
  Fix busted patches for games/nlarn from r400954.

  Noticed by:	antoine
  PR:		202499
  MFH:		2015Q4

Changes:
  head/games/nlarn/files/patch-src-monsters.c
  head/games/nlarn/files/patch-src-player.c
Comment 12 Torsten Zühlsdorff 2015-11-09 10:14:37 UTC
There was a fallout message shortly after the patch was committed. I took a look at it and saw, that the patch was not applied clean. For example the patch for monster.c has a duplicate patchset:

https://svnweb.freebsd.org/ports/head/games/nlarn/files/patch-src-monsters.c?revision=400954&view=co&pathrev=400979

I did not see this error in my patch and could not reproduce it. Therefore i do something wrong or an error at committer site happend. 

Can someone of the committers please have a look at it?
Comment 13 Torsten Zühlsdorff 2015-11-09 10:22:07 UTC
(In reply to Torsten Zühlsdorff from comment #12)

> Can someone of the committers please have a look at it?

Ah, sorry - i confused this history. The patch is already fixed. :)

Therefore: from my point of view everything is fine. The PR could be closed now.
Comment 14 Antoine Brodin freebsd_committer 2015-11-13 09:41:35 UTC
Close

I see no need to merge to quarterly  (running quarterly ports on base head is probably a bad idea)