Bug 202519 - [PATCH] Upgrade lang/jruby to 1.7.22
Summary: [PATCH] Upgrade lang/jruby to 1.7.22
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-ruby mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-20 14:16 UTC by Andrew Smith
Modified: 2015-09-07 15:10 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (ruby)


Attachments
diff against 1.7.15 (previous) version (299.78 KB, patch)
2015-08-20 14:16 UTC, Andrew Smith
no flags Details | Diff
port 1.7.15 to 1.7.22 (299.78 KB, patch)
2015-08-24 08:11 UTC, Andrew Smith
no flags Details | Diff
port 1.7.15 to 1.7.22 (300.71 KB, patch)
2015-09-07 13:09 UTC, Andrew Smith
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Smith 2015-08-20 14:16:22 UTC
Created attachment 160147 [details]
diff against 1.7.15 (previous) version

Update to include 1.7.21 with confirmed fixes for issues in jnr-ffi subcomponent problem processing libc.so script.

This effects many facets of JRuby including DRb with Unix Domain Sockets.
Comment 1 Andrew Smith 2015-08-24 08:11:51 UTC
Created attachment 160295 [details]
port 1.7.15 to 1.7.22
Comment 2 Michael Moll freebsd_committer 2015-09-07 00:24:16 UTC
I'm getting the following warnings/errors:

stage-qa:
Warning: 'share/jruby/lib/jni/x86_64-FreeBSD/libjffi-1.2.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}

check-plist:
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: %%JRUBY_HOME%%/lib/ruby/shared/digest/bubblebabble.rb
Error: Orphaned: %%JRUBY_HOME%%/lib/ruby/shared/jopenssl22/openssl.rb
Error: Orphaned: %%JRUBY_HOME%%/lib/ruby/shared/jopenssl22/openssl/bn.rb
Error: Orphaned: %%JRUBY_HOME%%/lib/ruby/shared/jopenssl22/openssl/buffering.rb
Error: Orphaned: %%JRUBY_HOME%%/lib/ruby/shared/jopenssl22/openssl/cipher.rb
Error: Orphaned: %%JRUBY_HOME%%/lib/ruby/shared/jopenssl22/openssl/config.rb
Error: Orphaned: %%JRUBY_HOME%%/lib/ruby/shared/jopenssl22/openssl/digest.rb
Error: Orphaned: %%JRUBY_HOME%%/lib/ruby/shared/jopenssl22/openssl/ssl.rb
Error: Orphaned: %%JRUBY_HOME%%/lib/ruby/shared/jopenssl22/openssl/x509.rb

Personally I can cope with the warning, but at least the plist errors need fixing.
Comment 3 Andrew Smith 2015-09-07 13:09:11 UTC
Created attachment 160801 [details]
port 1.7.15 to 1.7.22

Fixes plist and unstripped library issue.
Comment 4 commit-hook freebsd_committer 2015-09-07 15:09:41 UTC
A commit references this bug:

Author: mmoll
Date: Mon Sep  7 15:09:16 UTC 2015
New revision: 396275
URL: https://svnweb.freebsd.org/changeset/ports/396275

Log:
  lang/jruby: update to 1.7.22

  PR:		202519
  Submitted by:	Andrew Smith <iamasmith.home@gmail.com>

Changes:
  head/lang/jruby/Makefile
  head/lang/jruby/distinfo
  head/lang/jruby/pkg-plist
Comment 5 Michael Moll freebsd_committer 2015-09-07 15:10:21 UTC
commited, thanks!