Bug 202649 - databases/postgresql92-server: XML option not fully defined
Summary: databases/postgresql92-server: XML option not fully defined
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Some People
Assignee: pgsql
URL:
Keywords:
: 202287 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-08-25 10:38 UTC by Christoph Moench-Tegeder
Modified: 2015-12-02 20:51 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (pgsql)


Attachments
enable XML option (514 bytes, patch)
2015-08-25 10:38 UTC, Christoph Moench-Tegeder
no flags Details | Diff
poudriere testport postgresql92-server (449.46 KB, text/plain)
2015-08-25 10:58 UTC, Christoph Moench-Tegeder
no flags Details
poudriere testport postgresql93-server (498.36 KB, text/plain)
2015-08-25 10:59 UTC, Christoph Moench-Tegeder
no flags Details
poudriere testport postgresql94-server (514.13 KB, text/plain)
2015-08-25 11:00 UTC, Christoph Moench-Tegeder
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Moench-Tegeder freebsd_committer 2015-08-25 10:38:29 UTC
Created attachment 160342 [details]
enable XML option

Although the error is in postgresql92-server's Makefile, this affects PostgreSQL server versions 9.2, 9.3 and 9.4 via the include in 9.3's and 9.4's Makefile.
Accordingly, a PKGVERSION bump for all three PostgreSQL servers is recommended.

The xml2 PostgreSQL extension is not loadable as the xml_ereport() funtion is missing from postgresql, see https://lists.freebsd.org/pipermail/freebsd-ports/2015-August/100203.html
Additionally, xml support in postgresql is severely limited.
Debugging shows that all PostgreSQL server versions are built without XML support, as option XML is missing from OPTIONS_DEFINE and cannot be activated.

Attached patch fixes that.
Comment 1 Christoph Moench-Tegeder freebsd_committer 2015-08-25 10:58:53 UTC
Created attachment 160343 [details]
poudriere testport postgresql92-server

poudriere testport -j 10_2_amd64 -p testing -o databases/postgresql92-server
Comment 2 Christoph Moench-Tegeder freebsd_committer 2015-08-25 10:59:43 UTC
Created attachment 160344 [details]
poudriere testport postgresql93-server

poudriere testport -j 10_2_amd64 -p testing -o databases/postgresql93-server
Comment 3 Christoph Moench-Tegeder freebsd_committer 2015-08-25 11:00:29 UTC
Created attachment 160345 [details]
poudriere testport postgresql94-server

poudriere testport -j 10_2_amd64 -p testing -o databases/postgresql94-server
Comment 4 Christoph Moench-Tegeder freebsd_committer 2015-08-25 11:01:59 UTC
Attached poudriere logs (all 10.2 amd64) show that all postgresql servers now depend on libxml2 when built with default options.

cmt@elch:latest-per-pkg$ grep xml2 postgresql9*-server*log | grep NEEDED
postgresql92-server-9.2.13_1.log: 0x0000000000000001 (NEEDED)             Shared library: [libxml2.so.2]
postgresql93-server-9.3.9_1.log: 0x0000000000000001 (NEEDED)             Shared library: [libxml2.so.2]
postgresql94-server-9.4.4_1.log: 0x0000000000000001 (NEEDED)             Shared library: [libxml2.so.2]
Comment 5 Garrett Wollman freebsd_committer 2015-09-10 22:13:55 UTC
This bit me just now when doing a server upgrade; apparently it matters more for 9.4 than it did in 9.2.

-GAWollman
Comment 6 dennis.noordsij 2015-10-05 19:59:26 UTC
Agree with #5, the XML support is important for me (it can be behind an option of course). This broke unexpectedly (postgresql 9.4.4) after an update, the patch fixes it.
Comment 7 commit-hook freebsd_committer 2015-10-06 08:48:31 UTC
A commit references this bug:

Author: girgen
Date: Tue Oct  6 08:47:45 UTC 2015
New revision: 398690
URL: https://svnweb.freebsd.org/changeset/ports/398690

Log:
  Fix broken XML support.

  PR:	ports/202649

Changes:
  head/databases/postgresql92-contrib/Makefile
  head/databases/postgresql92-server/Makefile
  head/databases/postgresql93-contrib/Makefile
  head/databases/postgresql93-server/Makefile
  head/databases/postgresql94-contrib/Makefile
  head/databases/postgresql94-server/Makefile
Comment 8 Palle Girgensohn freebsd_committer 2015-10-06 08:51:05 UTC
Thanks for the report!
Comment 9 Palle Girgensohn freebsd_committer 2015-12-02 20:51:18 UTC
*** Bug 202287 has been marked as a duplicate of this bug. ***