Bug 202685 - [textproc/en-hunspell] upgrade port to version 2015.08.24
Summary: [textproc/en-hunspell] upgrade port to version 2015.08.24
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mikhail Teterin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-27 01:08 UTC by Joseph Mingrone
Modified: 2018-01-12 14:26 UTC (History)
6 users (show)

See Also:


Attachments
svn diff (2.62 KB, patch)
2015-08-27 01:08 UTC, Joseph Mingrone
no flags Details | Diff
poudriere testport log (14.24 KB, text/x-log)
2015-08-27 01:13 UTC, Joseph Mingrone
no flags Details
update the port, add option for en_GB dictionary, install required copyright files (4.27 KB, patch)
2015-08-30 03:31 UTC, Joseph Mingrone
jrm: maintainer-approval+
Details | Diff
Update the port, add more options and pkg-help (7.78 KB, patch)
2016-01-27 17:58 UTC, Mikhail Teterin
mi: maintainer-approval? (office)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Mingrone freebsd_committer 2015-08-27 01:08:09 UTC
Created attachment 160389 [details]
svn diff
Comment 1 Joseph Mingrone freebsd_committer 2015-08-27 01:11:36 UTC
1. I left the MASTER_SITES entry for LOCAL/sunpoet/${PORTNAME}/ assuming the latest distfiles will be uploaded there.

2. The en-GB dictionary comes in two version: -ise spelling and -ize spelling.  I chose the -ise spelling, but perhaps a port option to let the user choose would be best.  There are larger dictionaries and that for en-GB includes both spelling, but the authors discourage using the larger dictionaries because they promote inconsistent spelling and they are less tested.
Comment 2 Joseph Mingrone freebsd_committer 2015-08-27 01:13:04 UTC
Created attachment 160390 [details]
poudriere testport log

This was tested in a 10amd64 jail, but since the port defines NO_ARCH, I didn't include any other architecture logs.
Comment 3 Joseph Mingrone freebsd_committer 2015-08-27 03:14:04 UTC
There are two minor issue with these dictionary files.  I've contacted the creator to see if they fixed upstream.  If I don't hear from him shortly I'll added patches.
Comment 4 Joseph Mingrone freebsd_committer 2015-08-27 03:18:20 UTC
(In reply to Joseph Mingrone from comment #3)

That was almost incomprehensible, so let me try again.


There are two minor issues with these dictionary files.  I've contacted the creator to see if they can be fixed upstream.  If I don't hear from him shortly I'll will add patches.
Comment 5 Joseph Mingrone freebsd_committer 2015-08-30 03:31:14 UTC
Created attachment 160510 [details]
update the port, add option for en_GB dictionary, install required copyright files

A link will be made, by default, from ${LOCALBASE}/share/hunspell/en_GB-ise.{aff,diff} to ${LOCALBASE}/share/hunspell/en_GB.{aff,diff} unless the user selects the option to create the link to the en_GB-ize files.

Install the required copyright notices.

Update the comment about the licences.  It wasn't quite correct. Parts of the en_CA and en_US dictionaries are licensed under a BSD license (the affix files), but the dictionary files are not.

Poudriere testport logs with both the option off and on:

http://pkg.awarnach.mathstat.dal.ca/data/10amd64-default/2015-08-30_00h18m02s/logs/en-hunspell-2015.08.24.log

http://pkg.awarnach.mathstat.dal.ca/data/10amd64-default/2015-08-30_00h17m43s/logs/en-hunspell-2015.08.24.log
Comment 6 Joseph Mingrone freebsd_committer 2015-08-30 03:32:30 UTC
I forgot to mention that problems, confirmed to be problems upstream, have been corrected in the affix files.
Comment 7 Mark Linimon freebsd_committer freebsd_triage 2015-09-03 03:30:54 UTC
Reclassify.
Comment 8 Mikhail Teterin freebsd_committer 2016-01-27 15:31:40 UTC
I'll update this to the latest release (2016.01.19) and commit. Seems like "maintainer timeout" is justified here -- the current distfiles aren't even available any more.
Comment 9 Mikhail Teterin freebsd_committer 2016-01-27 17:58:22 UTC
Created attachment 166194 [details]
Update the port, add more options and pkg-help

This version uses the latest files from upstream and makes the following other changes:

1. The licenses no appear to be of BSD-kind throughout -- please, verify.
2. Only one pair of files (.aff and .dic) is installed for each of the three countries (CA, GB, US). Three groups of radio buttons allow the user to pick the variant (such as -ize vs. -ise) for each locale.
3. pkg-help added to guide user through the above selections.
4. pkg-descr expanded from upstream's README.

That said, I'm beginning to think, the port should be split-up into three -- people are unlikely to need dictionaries for all three countries... But this aspect has nothing to do with upgrading.
Comment 10 commit-hook freebsd_committer 2016-02-19 05:14:37 UTC
A commit references this bug:

Author: mi
Date: Fri Feb 19 05:14:17 UTC 2016
New revision: 409151
URL: https://svnweb.freebsd.org/changeset/ports/409151

Log:
  Make fetchable by upgrading. Add options for vocabularies and provide
  help-file for the user.

  PR:		202685
  Submitted by:	Joseph Mingrone
  Approved by:	maintainer timeout

Changes:
  head/textproc/en-hunspell/Makefile
  head/textproc/en-hunspell/distinfo
  head/textproc/en-hunspell/pkg-descr
  head/textproc/en-hunspell/pkg-help
Comment 11 John Marino freebsd_committer 2016-03-05 12:58:15 UTC
I just realized that the commit that broke en-hunspell came from this PR.  THis is what I just posted:

===============
On 2/19/2016 6:14 AM, Mikhail Teterin wrote:
> Author: mi
> Date: Fri Feb 19 05:14:17 2016
> New Revision: 409151
> URL: https://svnweb.freebsd.org/changeset/ports/409151
>
> Log:
>   Make fetchable by upgrading. Add options for vocabularies and provide
>   help-file for the user.
>   
>   PR:		202685
>   Submitted by:	Joseph Mingrone
>   Approved by:	maintainer timeout
>
> Added:
>   head/textproc/en-hunspell/pkg-help   (contents, props changed)
> Modified:
>   head/textproc/en-hunspell/Makefile
>   head/textproc/en-hunspell/distinfo
>   head/textproc/en-hunspell/pkg-descr
>
> Modified: head/textproc/en-hunspell/Makefile
> ==============================================================================
> --- head/textproc/en-hunspell/Makefile	Fri Feb 19 04:58:21 2016	(r409150)
> +++ head/textproc/en-hunspell/Makefile	Fri Feb 19 05:14:17 2016	(r409151)

[snip]

> +
> +COPY=	-lh	# Use hardlinks rather than copies under stage/

This line might be wrong.
intent: I'm not aware of anyway trying to install by stage via
hardlinks.  What is trying to be accomplished here?

# make -V INSTALL_DATA
install -lh -m 0644

So the -lh does indeed create hardlinks but this only works on FreeBSD.
 This command is not supported on DragonFly.

This is the only port in the tree that uses this method to populate the
stage directory (that I am aware of) so that's why I'd like to know what
problem this is addressing and why standard installation command cannot
(or maybe should not) be used.

Thanks,
John
===============

Can somebody explain why hardlinks are being used for installation?  It's the only port in the tree doing that.
Comment 12 John Marino freebsd_committer 2016-03-05 12:59:11 UTC
reopen to understand this hardlink thing.
Comment 13 Mikhail T. 2016-03-05 20:14:42 UTC
(In reply to John Marino from comment #11

Yes, the -lh creates hard links instead of copies, which saves both time and space during build. It is also guaranteed to work on FreeBSD, because WRKSRC and STAGEDIR are subdirectories of WRKDIR and thus are always on the same file system.

This port may be the only for now, but, I think, the flag should become the default. Maybe, DragonFlyBSD needs a different setting.
Comment 14 John Marino freebsd_committer 2016-03-05 20:17:29 UTC
even if DragonFly upgraded today, it would take 6 months because the command could be used.

That's assuming that portmgr agrees with your position.

I'm adding bapt@ to the CC so he knows what's going on.  I don't know if this approach is kosher or not.
Comment 15 John Marino freebsd_committer 2016-03-05 20:18:42 UTC
typo:
" because the command" => "before the command".

6 months being when the updated command would make to the current release (same as lowest common denomator for FreeBSD releases)
Comment 16 Joseph Mingrone freebsd_committer 2017-08-02 13:44:25 UTC
John, has this been resolved on DragonFly?  Can this be closed now?
Comment 17 Walter Schwarzenfeld freebsd_triage 2018-01-12 14:12:37 UTC
en-hunspell has version 2017.08.24. Could be closed.