Bug 202700 - timezone Europe/London is weird
Summary: timezone Europe/London is weird
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 10.1-RELEASE
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-27 21:36 UTC by ben
Modified: 2015-09-02 22:05 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ben 2015-08-27 21:36:59 UTC
% TZ=Europe/London date -r 0               
Thu Jan  1 01:00:00 BST 1970

Clearly, BST is not the correct timezone. However:

% TZ=GMT0BST date -r 0      
Thu Jan  1 00:00:00 GMT 1970

And also surprisingly:

% TZ=Europe/Paris date -r 0 
Thu Jan  1 01:00:00 CET 1970

Which is correct.
Comment 1 Jilles Tjoelker freebsd_committer 2015-09-02 22:05:15 UTC
This appears to be an upstream (tzdata) issue. Please ask there.

If the issue is FreeBSD-specific anyway or tzcode updates are needed, please reopen this bug.