Bug 202824 - dns/dnstracer: Build fails on 10.2-RELEASE-p2 amd64 (config.status: error: invalid argument: depfiles)
Summary: dns/dnstracer: Build fails on 10.2-RELEASE-p2 amd64 (config.status: error: in...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords: easy, patch
Depends on:
Blocks:
 
Reported: 2015-09-02 07:20 UTC by Vikash Badal
Modified: 2016-04-11 18:46 UTC (History)
6 users (show)

See Also:
pi: maintainer-feedback-
pi: merge-quarterly-


Attachments
poudriere build fail log (10.10 KB, text/plain)
2016-01-02 15:44 UTC, Lukasz Wasikowski
no flags Details
poudriere-dns_dnstracer.log (38.37 KB, text/x-log)
2016-01-19 10:24 UTC, w.schwarzenfeld
no flags Details
svn-diff_dns_dnstracker_hack (766 bytes, patch)
2016-01-19 14:27 UTC, w.schwarzenfeld
no flags Details | Diff
svn-diff_dns_dnstracer (628 bytes, patch)
2016-01-19 14:56 UTC, w.schwarzenfeld
no flags Details | Diff
poudriere-dns_dnstracer-new_jail.log (41.14 KB, text/x-log)
2016-01-19 14:59 UTC, w.schwarzenfeld
no flags Details
portlint_dns_dnstracer (173 bytes, text/plain)
2016-01-19 15:01 UTC, w.schwarzenfeld
no flags Details
poudriere-dns_dnstracer-new_jail.log (41.19 KB, text/x-log)
2016-01-20 09:01 UTC, w.schwarzenfeld
no flags Details
svn-diff_dns_dnstracer-1.9_1 (1.67 KB, patch)
2016-01-20 09:02 UTC, w.schwarzenfeld
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vikash Badal 2015-09-02 07:20:02 UTC
===>  Building for dnstracer-1.9
gmake[1]: Entering directory '/wrkdirs/usr/ports/dns/dnstracer/work/dnstracer-1.9'
cd . && /bin/sh ./config.status Makefile depfiles
config.status: error: invalid argument: depfiles
Makefile:132: recipe for target 'Makefile' failed
gmake[1]: *** [Makefile] Error 1
gmake[1]: Leaving directory '/wrkdirs/usr/ports/dns/dnstracer/work/dnstracer-1.9'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make: stopped in /usr/ports/dns/dnstracer
====>> Cleaning up wrkdir
===>  Cleaning for dnstracer-1.9


Poudriere version: 3.1.7
Host OSVERSION: 1002000
Jail OSVERSION: 1002000

---Begin Environment---
OSVERSION=1002000
UNAME_v=FreeBSD 10.2-RELEASE-p2
UNAME_r=10.2-RELEASE-p2
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
SAVED_TERM=
MASTERMNT=/data/poudriere/data/.m/RELENG_10_2_amd64-default/ref
FORCE_PACKAGE=yes
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=dnstracer-1.9
OLDPWD=/
PWD=/data/poudriere/data/.m/RELENG_10_2_amd64-default/ref/.p/pool
MASTERNAME=RELENG_10_2_amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.7
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for dnstracer-1.9:
     IPV6=on: IPv6 protocol support
===> Use 'make config' to modify these settings
---End OPTIONS List---
Comment 1 Bartek Rutkowski freebsd_committer 2016-01-02 08:19:09 UTC
I've tested the port and can't reproduce your build issue. Any chance you could try to reproduce it on a freshly installed and updated 10.2-RELEASE build in a virtual machine or something similar?
Comment 2 Lukasz Wasikowski 2016-01-02 15:44:51 UTC
Created attachment 164960 [details]
poudriere build fail log

Log from poudriere's failed build on FreeBSD 10.2-RELEASE-p8.
Comment 3 Lukasz Wasikowski 2016-01-19 09:07:57 UTC
Any progress on this? QA is provided, so needs-qa keyword can be deleted.
Comment 4 w.schwarzenfeld 2016-01-19 10:24:09 UTC
Created attachment 165806 [details]
poudriere-dns_dnstracer.log
Comment 5 w.schwarzenfeld 2016-01-19 10:24:48 UTC
As you see, builds fine on my system.
Comment 6 Lukasz Wasikowski 2016-01-19 11:34:58 UTC
I see. Could you test it on a fresh system?

I've installed fresh FreeBSD 10.2 64-bit (with default settings, install on UFS) on new VM. Then I did:

freebsd-update fetch install
shutdown -r now
pkg
pkg install poudriere
poudriere jail -c -j freebsd-10-test -v 10.2-RELEASE
mkdir -p /usr/ports/distfiles
poudriere ports -c
poudriere bulk -j freebsd-10-test dns/dnstracer

and I got the same error I posted before. The same error that OP reported. There is something is wrong with this port.
Comment 7 w.schwarzenfeld 2016-01-19 14:24:54 UTC
The Makefile is missing USES= autoreconf. The svn-diff is a not really clean hack. Because the were problem install the manfile (should work). But there a warnings with portlint. But these compiles in the port and with poudriere. Makefile should reworked.
Comment 8 w.schwarzenfeld 2016-01-19 14:27:32 UTC
Created attachment 165820 [details]
svn-diff_dns_dnstracker_hack
Comment 9 w.schwarzenfeld 2016-01-19 14:30:08 UTC
Forget: you were right, first poudriere fails in a new poudriere jail (cause the autoconf ports were not installed - see autoreconf).
Comment 10 w.schwarzenfeld 2016-01-19 14:53:55 UTC
Portlint is ok (I forgot to delete something). svn-diff should now be ok.
Comment 11 w.schwarzenfeld 2016-01-19 14:56:20 UTC
Created attachment 165821 [details]
svn-diff_dns_dnstracer
Comment 12 w.schwarzenfeld 2016-01-19 14:59:42 UTC
Created attachment 165823 [details]
poudriere-dns_dnstracer-new_jail.log
Comment 13 w.schwarzenfeld 2016-01-19 15:01:58 UTC
Created attachment 165825 [details]
portlint_dns_dnstracer
Comment 14 w.schwarzenfeld 2016-01-20 08:00:30 UTC
I was  wondering about the port makes warnings: "autoconf not found", automake no found ...", poudriere not.
Comment 15 Kubilay Kocak freebsd_committer freebsd_triage 2016-01-20 08:22:29 UTC
@Walter,

CONFIGURE_ARGS can be removed, --prefix is set by default (Please confirm with make -V CONFIGURE_ARGS

Why are the man pages being installed pre and not post install?

Please also obsolete superseded attachments/logs

@Edwin, it would be great if your port MAINTAINER lines matched your @FreeBSD.org account such that new issues for your ports can/could be automatically assigned
Comment 16 w.schwarzenfeld 2016-01-20 09:01:40 UTC
Created attachment 165852 [details]
poudriere-dns_dnstracer-new_jail.log
Comment 17 w.schwarzenfeld 2016-01-20 09:02:50 UTC
Created attachment 165853 [details]
svn-diff_dns_dnstracer-1.9_1
Comment 18 w.schwarzenfeld 2016-01-20 09:04:42 UTC
I changed it, plus a small patch cause of an deprecated warning in configure.in.

 make -V CONFIGURE_ARGS
--enable---disable-ipv6 --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
Comment 19 Lukasz Wasikowski 2016-01-31 09:49:53 UTC
This patch works for me, thank you.
Comment 20 Kurt Jaeger freebsd_committer 2016-02-17 04:30:19 UTC
Testbuilds OK, portlint OK.
Comment 21 commit-hook freebsd_committer 2016-02-17 04:30:58 UTC
A commit references this bug:

Author: pi
Date: Wed Feb 17 04:30:29 UTC 2016
New revision: 409029
URL: https://svnweb.freebsd.org/changeset/ports/409029

Log:
  dns/dnstracer: fix build on 10.2amd64

  PR:		202824
  Submitted by:	w.schwarzenfeld@aon.at, lukasz@wasikowski.net, vikashb@where-ever.za.net
  Approved by:	edwin (maintainer timeout)

Changes:
  head/dns/dnstracer/Makefile
  head/dns/dnstracer/files/
  head/dns/dnstracer/files/patch-configure.in
Comment 22 Kubilay Kocak freebsd_committer freebsd_triage 2016-02-17 04:35:11 UTC
Triage post initial HEAD commit

Pending MFH
Comment 23 Kubilay Kocak freebsd_committer freebsd_triage 2016-02-17 04:35:45 UTC
Comment on attachment 165853 [details]
svn-diff_dns_dnstracer-1.9_1

Maintainer timeout, implicit approval
Comment 24 Kurt Jaeger freebsd_committer 2016-04-11 18:46:39 UTC
Went into the Q2 quarterly.