Bug 202867 - mod_php* packages should provide .conf files to ease set up of apache
Summary: mod_php* packages should provide .conf files to ease set up of apache
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Walter Schwarzenfeld
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-03 11:15 UTC by rearnsha
Modified: 2019-08-08 12:56 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rearnsha 2015-09-03 11:15:20 UTC
The apache configuration system is pretty modular and management of upgrades is considerably eased if most of the configuration is (semi-)automatic.

In particular, the mod_php* packages could be installed without requiring any edits to httpd.conf if the packages came with .conf files for the modules and the Includes directories; administrators simply create symlinks to these files and the server is now configured.  Example contents would be:

etc/apache24/modules.d/<nnn>-mod_php.conf:
LoadModule php5_module        libexec/apache24/libphp5.so

etc/apache24/Includes/mod_php.conf:
IfModule php5_module>
  AddType application/x-httpd-php .php
  AddType application/x-httpd-php-source .phps
</IfModule>

Alternatively the files could be installed directly into the apache configuration directories then all that is needed is a simple restart.
Comment 1 rearnsha 2015-09-03 11:16:39 UTC
(In reply to rearnsha from comment #0)
pasto error:  First line of etc/apache24/Includes/mod_php.conf should read:
<IfModule php5_module>
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2015-09-03 17:34:14 UTC
Assign to maintainer.
Comment 3 ThomasStiltner 2017-01-11 12:07:47 UTC
As for me, Apache web server is perfect tool for serving HTTP traffic. However, a lot of problems with this web server which happen quite often. For example, I one time I had debugging script execution problems. Didn't know how to solve them for quite a long time until I addressed experts at http://www.writemyessay24h.net/write-my-thesis.php.
 As it a appeared, the reason problem was minor 
%% 500 /var/tmp/apache/cgi-bin/print
%request
Accept: */*
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/5.0 (PPC Mac OS X; en) AppleWebKit/418.9.1 (KHTML, like Gecko) Safari/419.3
Host: 192.168.1.3:80
%response Safari/419.3
Script /cgi-bin/print
Agent: Mozilla/5.0 418.9.1
Accept: */*
Comment 4 Walter Schwarzenfeld freebsd_triage 2018-01-14 03:44:23 UTC
Maintainer feedback?
Comment 5 Walter Schwarzenfeld freebsd_triage 2019-08-08 12:56:25 UTC
it is rather a discussion for https://lists.freebsd.org/pipermail/freebsd-ports/ .
This is not bug. I close here, after two years with no action.
If you think, it is somethings left, reopen.