Bug 202960 - Kernel panic when bridging e1000 NIC with pf rules
Summary: Kernel panic when bridging e1000 NIC with pf rules
Status: Closed DUPLICATE of bug 202351
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.2-RELEASE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-net mailing list
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2015-09-07 22:11 UTC by jeffrey
Modified: 2015-09-10 00:14 UTC (History)
2 users (show)

See Also:


Attachments
core.txt (164.80 KB, text/plain)
2015-09-07 22:11 UTC, jeffrey
no flags Details
pf rules (635 bytes, text/plain)
2015-09-07 22:12 UTC, jeffrey
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description jeffrey 2015-09-07 22:11:07 UTC
Created attachment 160825 [details]
core.txt

When trying to set up a tap device for bhyve, I ran into a kernel panic with some combination of the e1000 drivers for my Intel NIC and pf forwarding of IPv6 packets. I was following the instructions on the bhyve page for setting up the tap device and bridge: https://www.freebsd.org/doc/handbook/virtualization-host-bhyve.html which worked fine until I try to bring up the bridge, at which point it will panic shortly after (presumably when it gets an IPv6 multicast packet).

The crash appears to be a bad interaction between the e1000 driver and ip6_forward, where it panics when trying to log that it can't forward multicast messages. The name of the interface in one of the mbufs is null, leading to a fault when it tries to strlen the argument to kvprintf.

core.txt is attached.
Comment 1 jeffrey 2015-09-07 22:12:02 UTC
Created attachment 160826 [details]
pf rules
Comment 2 jeffrey 2015-09-09 00:13:16 UTC
I was able to work around this by adding a pf rule that drops incoming IPv6 multicast traffic to em0. Suboptimal, but no more kernel panics.
Comment 3 Andrey V. Elsukov freebsd_committer 2015-09-10 00:14:05 UTC

*** This bug has been marked as a duplicate of bug 202351 ***