Bug 203163 - devel/ice: Support building against LibreSSL and OpenSSL from ports
Summary: devel/ice: Support building against LibreSSL and OpenSSL from ports
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Michael Gmelin
URL:
Keywords:
: 198781 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-09-16 23:18 UTC by Michael Gmelin
Modified: 2015-09-16 23:45 UTC (History)
2 users (show)

See Also:
grembo: maintainer-feedback+


Attachments
Patch to allow building devel/ice with LibreSSL and OpenSSL from ports (13.34 KB, patch)
2015-09-16 23:18 UTC, Michael Gmelin
grembo: maintainer-approval+
Details | Diff
poudriere output of build on 9.3-RELEASE against LibreSSL (496.92 KB, text/plain)
2015-09-16 23:22 UTC, Michael Gmelin
no flags Details
poudriere output of build on 9.3-RELEASE against OpenSSL from base (496.92 KB, text/plain)
2015-09-16 23:23 UTC, Michael Gmelin
no flags Details
poudriere output of build on 9.3-RELEASE against OpenSSL from ports (497.13 KB, text/plain)
2015-09-16 23:24 UTC, Michael Gmelin
no flags Details
poudriere output of build on 10.2-RELEASE against LibreSSL (525.77 KB, text/plain)
2015-09-16 23:25 UTC, Michael Gmelin
no flags Details
poudriere output of build on 10.2-RELEASE against OpenSSL from base (525.67 KB, text/plain)
2015-09-16 23:25 UTC, Michael Gmelin
no flags Details
poudriere output of build on 10.2-RELEASE against OpenSSL from ports (527.14 KB, text/plain)
2015-09-16 23:26 UTC, Michael Gmelin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Gmelin freebsd_committer 2015-09-16 23:18:11 UTC
Created attachment 161128 [details]
Patch to allow building devel/ice with LibreSSL and OpenSSL from ports

devel/ice didn't build against OpenSSL from ports (even though it built, but the resulting binaries weren't linkes properly). It wouldn't really work using LibreSSL at all due a couple of minor issues.

The attached patch fixes all of this plus an issue that prevented build devel/ice with iconv from ports.
Comment 1 Michael Gmelin freebsd_committer 2015-09-16 23:22:48 UTC
Created attachment 161129 [details]
poudriere output of build on 9.3-RELEASE against LibreSSL
Comment 2 Michael Gmelin freebsd_committer 2015-09-16 23:23:58 UTC
Created attachment 161130 [details]
poudriere output of build on 9.3-RELEASE against OpenSSL from base
Comment 3 Michael Gmelin freebsd_committer 2015-09-16 23:24:28 UTC
Created attachment 161131 [details]
poudriere output of build on 9.3-RELEASE against OpenSSL from ports
Comment 4 Michael Gmelin freebsd_committer 2015-09-16 23:25:13 UTC
Created attachment 161132 [details]
poudriere output of build on 10.2-RELEASE against LibreSSL
Comment 5 Michael Gmelin freebsd_committer 2015-09-16 23:25:40 UTC
Created attachment 161133 [details]
poudriere output of build on 10.2-RELEASE against OpenSSL from base
Comment 6 Michael Gmelin freebsd_committer 2015-09-16 23:26:12 UTC
Created attachment 161134 [details]
poudriere output of build on 10.2-RELEASE against OpenSSL from ports
Comment 7 Michael Gmelin freebsd_committer 2015-09-16 23:34:43 UTC
*** Bug 198781 has been marked as a duplicate of this bug. ***
Comment 8 commit-hook freebsd_committer 2015-09-16 23:39:37 UTC
A commit references this bug:

Author: grembo
Date: Wed Sep 16 23:38:59 UTC 2015
New revision: 397092
URL: https://svnweb.freebsd.org/changeset/ports/397092

Log:
  Support building against LibreSSL and OpenSSL from ports.
  Also fixes building against iconv from ports.

  PR:		203163
  Approved by:	mentors (implicit)

Changes:
  head/devel/ice/Makefile
  head/devel/ice/files/Make.rules.FreeBSD
  head/devel/ice/files/patch-cpp-config-Make.rules
  head/devel/ice/files/patch-cpp-src-IceSSL-Makefile
  head/devel/ice/files/patch-cpp-src-IceSSL-OpenSSLEngine.cpp
  head/devel/ice/files/patch-cpp-test-IceSSL-configuration-AllTests.cpp
  head/devel/ice/files/patch-cpp-test-IceSSL-configuration-run.py