Bug 203192 - graphics/dri failes to build on 10.2-p3 search way to disable GALLIUM or remove dri
Summary: graphics/dri failes to build on 10.2-p3 search way to disable GALLIUM or remo...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: x11
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-18 14:56 UTC by Walter Schwarzenfeld
Modified: 2015-09-28 11:27 UTC (History)
6 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
dr-build.log (74.69 KB, text/plain)
2015-09-18 15:55 UTC, Walter Schwarzenfeld
no flags Details
build with MAKE_JOBS_UNSAFE=yes (180.60 KB, text/plain)
2015-09-18 18:35 UTC, philipp
no flags Details
build log make V=1 (130.88 KB, application/gzip)
2015-09-22 08:37 UTC, philipp
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Schwarzenfeld 2015-09-18 14:56:27 UTC
Fail to build with all compilers (clang36, clang35, gcc48, gcc5. With different error-messages in the directory GALLIUM. (FreeBSD-10.2-p3 amd64).
I removed dri. Seems makes no problem. But if I ever would update x11-servers/xorg-server , it will pull in it again.
I searching a way to exclude GALLIUM from compiling. WITH_GALLIUM=NO does not help. Or remove dri complete.

Some detail here in the forum: https://forums.freebsd.org/threads/update-graphics-dri-failure.53253/#post-299243
Comment 1 Walter Schwarzenfeld 2015-09-18 14:57:33 UTC
Forgot it compiles with poudriere. (But I dont't like to spent two hours for compiling dri with poudriere. Normally it compiles with portmaster and in the port fewer than ten minutes).
Comment 2 Walter Schwarzenfeld 2015-09-18 15:55:48 UTC
Created attachment 161168 [details]
dr-build.log
Comment 3 philipp 2015-09-18 18:35:54 UTC
Created attachment 161178 [details]
build with MAKE_JOBS_UNSAFE=yes
Comment 4 Walter Schwarzenfeld 2015-09-18 23:54:22 UTC
Graphics/libosmesa fails with the same error. Seems the error is located there.
Comment 5 Walter Schwarzenfeld 2015-09-19 12:51:25 UTC
If I run:
 make LLVM_CONFIG="-disable-checker"
I got:
gmake[5]: Entering directory '/usr/ports/graphics/dri/work/mesa-10.6.6/src/gallium/targets/opencl'
  CXXLD    libMesaOpenCL.la
/usr/bin/ld: cannot find -ldl

but find in the moment no solution.
Comment 6 Koop Mast freebsd_committer 2015-09-20 22:23:12 UTC
Could you try to deinstall dri and try again after a make clean?
Comment 7 Walter Schwarzenfeld 2015-09-20 22:48:49 UTC
Tried this three or four times last days. Now I do it again. Run make without LLVM_CONFIG=-disable-checker.
I don't get the "original" error message:
gmake[5]: Entering directory '/usr/ports/graphics/dri/work/mesa-10.6.6/src/gallium/targets/opencl'
  CXXLD  libMesaOpenCL.la
/usr/local/llvm36/lib/libclangFrontendTool.a(ExecuteCompilerInvocation.o): In function `clang::ExecuteCompilerInvocation(clang::CompilerInstance*)':
ExecuteCompilerInvocation.cpp:(.text._ZN5clang25ExecuteCompilerInvocationEPNS_16CompilerInstanceE+0x3f1): undefined reference to `clang::ento::printCheckerHelp(llvm::raw_ostream&, llvm::ArrayRef<std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > >)' .....

Now I got as above:
gmake[5]: Entering directory '/usr/ports/graphics/dri/work/mesa-10.6.6/src/gallium/targets/opencl'
  CXXLD    libMesaOpenCL.la
/usr/bin/ld: cannot find -ldl
c++: error: linker command failed with exit code 1 (use -v to see invocation).
Comment 8 Walter Schwarzenfeld 2015-09-20 23:57:19 UTC
I write a patch (only for me) to comment out the line 676 in /usr/ports/graphics/dri/work/mesa-10.6.6/src/gallium/targets/opencl/Makefile as temporary solution (if I need in case of an update). In moment I use the package from poudriere.
Comment 9 Walter Schwarzenfeld 2015-09-21 15:41:28 UTC
In the meantime there is a official package of the new version.
Comment 10 Walter Schwarzenfeld 2015-09-21 16:09:04 UTC
Could it be, it has something to do, with that I have a amd processor?
Comment 11 Jean-Sébastien Pédron freebsd_committer 2015-09-21 21:39:47 UTC
Hi!

Could you please try to build graphics/dri with "make V=1" using the default compiler?

GALLIUM is not an option (it would be enabled by default anyway) and we will not make it optional. Managing the Mesa ports takes already enough time, sorry :(
Comment 12 Walter Schwarzenfeld 2015-09-21 22:03:46 UTC
make V=1 with clang36 same result.
Comment 13 Jean-Sébastien Pédron freebsd_committer 2015-09-22 06:40:35 UTC
Sorry, I was not clear: I'm interested in the build output.

V=1 is here to make the output of an automake-based build more verbose.
Comment 14 philipp 2015-09-22 08:37:03 UTC
Created attachment 161262 [details]
build log make V=1
Comment 15 philipp 2015-09-25 09:50:59 UTC
> Could it be, it has something to do, with that I have a amd processor?

Could be, on my intel cpu it builds without problem, on amd it fails.
Comment 16 concatmap 2015-09-25 18:31:55 UTC
I can't build dri and libosmesa. And my cpu is intel.
CPU: Intel(R) Core(TM) i5-4250U CPU @ 1.30GHz (1895.65-MHz K8-class CPU)
Comment 17 oleksii.tsai 2015-09-26 05:41:38 UTC
I was facing the same issue and couldn't find a way to get graphics/dri updated. The steps that seemed to unblock me were:
1. Install devel/llvm37.
2. Deinstall devel/llvm36.
This step had issues and reported some files were mismatching the checksum, therefore were not removed, so I removed /usr/local/llvm36 with a plain rm -rf command.
3. Reinstall devel/llvm36.
4. Reinstall libglapi.
5. Reinstall graphics/dri.

At this point was able to update all GL related libraries.
Tempted to say that step 1 is not needed, but haven't tried without it as I got dri package upgraded.
Comment 18 Walter Schwarzenfeld 2015-09-26 08:20:26 UTC
Was slightly different for me - delete llvm36 and compile llvm36 new does not help.
I hat to compile clang36 new, and libglapi, but it works, thanks.
Comment 19 Walter Schwarzenfeld 2015-09-26 08:43:19 UTC
But get 
pkg-static: Unable to access file /usr/ports/graphics/dri/work/stage/usr/local/%%SWRAST_DRIVER%%lib/dri/swrast_dri.so: No such file or directory
if I want to install. 
Fixed it with genplist.

And then:

Installing dri-10.6.6,2...
pkg-static: dri-10.6.6,2 conflicts with libEGL-10.6.6 (installs files into the same place).  Problematic file: /usr/local/include/EGL/egl.h
Comment 20 Walter Schwarzenfeld 2015-09-26 09:01:47 UTC
Genplist make nonsense. Fetched a new pkg-plist, now it works.
Comment 21 Walter Schwarzenfeld 2015-09-28 11:27:14 UTC
Next update is working fine, I close the PR.