Bug 203274 - misc/freebsd-doc-en: add missing links to plist, add NO_ARCH
Summary: misc/freebsd-doc-en: add missing links to plist, add NO_ARCH
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: doceng
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-23 01:19 UTC by Dmitry Marakasov
Modified: 2015-11-23 20:28 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (doceng)


Attachments
Patch (583 bytes, patch)
2015-09-23 01:19 UTC, Dmitry Marakasov
no flags Details | Diff
Patch (1.21 KB, patch)
2015-09-23 02:25 UTC, Dmitry Marakasov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Marakasov freebsd_committer 2015-09-23 01:19:15 UTC
Created attachment 161292 [details]
Patch

===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: %%PORTDOCS%%%%DOCSDIR%%/faq
Error: Orphaned: %%PORTDOCS%%%%DOCSDIR%%/handbook
===> Checking for items in pkg-plist which are not in STAGEDIR

Full log:
http://poudriere.amdmi3.ru/data/10-amd64-default/failures_all_2015_09_20/logs/errors/en-freebsd-doc-47011,1.log

- Add these missing links to plist
- Add NO_ARCH
Comment 1 Dmitry Marakasov freebsd_committer 2015-09-23 02:25:10 UTC
Created attachment 161293 [details]
Patch

Updated patch: also fixes plist for TXT format
Comment 2 Marc Fonvieille freebsd_committer 2015-09-27 14:31:53 UTC
Hello,

Looking at textproc/docproj ( a BUILD_DEPENDS), we have ONLY_FOR_ARCHS= amd64 i386, so we should prefer to add the same knob instead of No_ARCH.  Am I right?

--
Marc
Comment 3 Dmitry Marakasov freebsd_committer 2015-09-28 02:20:32 UTC
> Looking at textproc/docproj ( a BUILD_DEPENDS), we have ONLY_FOR_ARCHS=
> amd64 i386, so we should prefer to add the same knob instead of No_ARCH.  Am
> I right?

No. ONLY_FOR_ARCHS in docproj (which is essentially a metaport) doesn't seem correct at all. I guess it was propagated through fop from java which is ONLY_FOR_ARCHS=i386 amd64, and such propagation is totally wrong.

Regarding freebsd-doc-en, there's just no way for documentation to be limited to specific architectures, so there may never be any ONLY_FOR_ARCHS for this port.

And for the note, NO_ARCH and ONLY_FOR_ARCHS don't conflict and may happily live together.
Comment 4 Dmitry Marakasov freebsd_committer 2015-10-01 15:06:01 UTC
pkg-plist.txt bit still needs to be committed. Also after the latest update it doesn't build with PS:

https://people.freebsd.org/~amdmi3/freebsd-doc-en-ps.log
Comment 5 Marc Fonvieille freebsd_committer 2015-10-03 16:36:20 UTC
(In reply to Dmitry Marakasov from comment #4)
For the pkg-plist, I forgot it.  I'll fix it soon.

Regarding the break you experience, I think you hit a xsltproc issue.
Here I can't reproduce it, xsltproc --version gives
"Using libxml 20902, libxslt 10128 and libexslt 817"

Your logs indicate:
"You can adjust xsltMaxDepth (--maxdepth) in order to raise the maximum number of nested template calls and variables/params (currently set to 3000)."

Here, by default --maxdepth is set to 6000.
Comment 6 commit-hook freebsd_committer 2015-10-10 10:48:10 UTC
A commit references this bug:

Author: blackend
Date: Sat Oct 10 10:47:14 UTC 2015
New revision: 398987
URL: https://svnweb.freebsd.org/changeset/ports/398987

Log:
  Remove duplicate plist entries.

  PR:		203274
  Submitted by:	Dmitry Marakasov <amdmi3@FreeBSD.org>
  Approved by:	doceng (implicit)

Changes:
  head/misc/freebsd-doc-all/Makefile
  head/misc/freebsd-doc-de/pkg-plist.txt
  head/misc/freebsd-doc-en/Makefile
  head/misc/freebsd-doc-en/pkg-plist.txt
  head/misc/freebsd-doc-pt/pkg-plist.txt