Bug 203311 - graphics/openjpeg: build broken
Summary: graphics/openjpeg: build broken
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-24 15:35 UTC by tilghman
Modified: 2015-12-08 08:46 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (sunpoet)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tilghman 2015-09-24 15:35:37 UTC
Port build process is currently broken:

-- Checking for 64-bit off_t
-- Checking for 64-bit off_t - present
-- Checking for fseeko/ftello
-- Checking for fseeko/ftello - present
-- Large File support - found
CMake Error at src/lib/openjp2/CMakeLists.txt:89 (target_compile_options):
  Unknown CMake command "target_compile_options".


-- Configuring incomplete, errors occurred!
*** [do-configure] Error code 1

Stop in /usr/ports/graphics/openjpeg.
Comment 1 Sunpoet Po-Chuan Hsieh freebsd_committer 2015-09-24 16:38:57 UTC
I cannot reproduce this problem. According to [1], openjpeg 2.1.1 builds fine on all build environments. In order to investigate the build failure on your system, please provide more further information. Thanks!

[1] http://portsmon.freebsd.org/portoverview.py?category=graphics&portname=openjpeg
Comment 2 tilghman 2015-09-24 16:49:24 UTC
Looks like it's missing a dependency on a later version of CMake.  We have 2.8.10.2 here.
Comment 3 Sunpoet Po-Chuan Hsieh freebsd_committer 2015-11-29 16:22:03 UTC
Add kde@ (CMake maintainer) to Cc list. I wonder if we need to add version requirement in Mk/Uses/cmake.mk to have newer cmake installed.
Comment 4 Raphael Kubo da Costa freebsd_committer 2015-11-29 18:12:55 UTC
I don't think kde@ can do much -- if we go down that route, it means checking if each port for new commands or behavior changes that rely on a certain version and requiring that. What upstream should do is either bump their minimum version requirement or at least do what they did here: https://github.com/uclouvain/openjpeg/commit/c5dd6035c942ab5969b7dc3a873e95e3b542f544
Comment 5 Sunpoet Po-Chuan Hsieh freebsd_committer 2015-12-05 17:54:26 UTC
(In reply to Raphael Kubo da Costa from comment #4)

I will add a BUILD_DEPENDS to graphics/openjpeg to ensure a newer cmake is installed.
Thanks!
Comment 6 commit-hook freebsd_committer 2015-12-06 17:52:22 UTC
A commit references this bug:

Author: sunpoet
Date: Sun Dec  6 17:51:50 UTC 2015
New revision: 403133
URL: https://svnweb.freebsd.org/changeset/ports/403133

Log:
  - Add BUILD_DEPENDS for cmake version requirement

  PR:		203311
  Reported by:	Tilghman Lesher <tilghman@meg.abyt.es>

Changes:
  head/graphics/openjpeg/Makefile
Comment 7 Sunpoet Po-Chuan Hsieh freebsd_committer 2015-12-08 08:46:57 UTC
Committed. Thanks!