Bug 203363 - sshd fails to start
Summary: sshd fails to start
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 10.1-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-26 04:30 UTC by Alan Cummings
Modified: 2015-09-26 14:54 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Cummings 2015-09-26 04:30:51 UTC
When I run /usr/sbin/sshd -t I get this:
> /usr/sbin/sshd -t
bad addr or host: :: (hostname nor servname provided, or not known)

I have tried rebooting and changing the hostname. The result is the same whether the -t flag is present or not. Other services (nginx, webmin) still work. The sshd service used to work until about a day ago. There have been changes to the networking, such as switching from fixed IP to DHCP, moving to a DMZ, but no new ports or packages shave been installed recently.

If I try to start as a service, I get this:
> service sshd start
Performing sanity check on sshd configuration.
bad addr or host: :: (hostname nor servname provided, or not known)
/etc/rc.d/sshd: WARNING: failed precmd routine for sshd

The output of uname -a:
> uname -a
FreeBSD darkbsd-1 10.1-RELEASE-p6 FreeBSD 10.1-RELEASE-p6 #0: Tue Feb 24 19:00:21 UTC 2015     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64