Bug 203381 - [patch] mark mail/thunderbird BROKEN on sparc64
Summary: [patch] mark mail/thunderbird BROKEN on sparc64
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: sparc64 Any
: --- Affects Some People
Assignee: freebsd-gecko mailing list
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2015-09-26 17:16 UTC by Mark Linimon
Modified: 2016-11-03 22:59 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (gecko)


Attachments
patch for mail/thunderbird (463 bytes, patch)
2015-09-26 17:16 UTC, Mark Linimon
jbeich: maintainer-approval-
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Linimon freebsd_committer freebsd_triage 2015-09-26 17:16:12 UTC
Created attachment 161441 [details]
patch for mail/thunderbird

I am trying to figure out how much of sparc64 builds these days.  This port does not build and I would like permission to mark it BROKEN as I try to get a complete build.  Thanks.
Comment 1 craig001 2015-09-29 20:52:25 UTC
an attempt to raise the issue/get a fix -- see PR 186396
Comment 2 craig001 2015-09-29 21:11:00 UTC
old thunderbird fix for sparc64 see PR 186580
Comment 3 Steve Wills freebsd_committer 2015-10-12 15:25:41 UTC
Permission granted, though I would think this type of change would be covered under blanket approvals (or should be if it's not).
Comment 4 Jan Beich freebsd_committer 2016-03-04 17:35:40 UTC
Comment on attachment 161441 [details]
patch for mail/thunderbird

Wouldn't the underlying issue affect all gecko@ ports with browser engine? mail/thunderbird uses same engine as www/firefox-esr.

Also, I don't like the vague description. In case the issue is fixed upstream there's no way to discover or backport fix due to complete lack of details. Post a full build log that won't disappear in a year and/or fill in BROKEN with one line error excerpt.
Comment 5 Jan Beich freebsd_committer 2016-03-04 17:44:57 UTC
(In reply to craig001 from comment #2)
> old thunderbird fix for sparc64 see PR 186580

That fix was upstreamed years ago. Later sparc64 conditional migrated from Makefile.in to moz.build.

https://hg.mozilla.org/mozilla-central/rev/0688cd4ca145
https://dxr.mozilla.org/mozilla-central/rev/2b5237c178ea/xpcom/reflect/xptcall/md/unix/moz.build#259