Bug 203416 - x11/rxvt-unicode: gets stuck, won't create new clients / open new tabs via tabbed extension
Summary: x11/rxvt-unicode: gets stuck, won't create new clients / open new tabs via ta...
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thierry Thomas
URL:
Keywords:
: 203415 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-09-28 15:07 UTC by Tony Narlock
Modified: 2017-01-16 10:55 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (thierry)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Narlock 2015-09-28 15:07:38 UTC
This started happening only a few days ago (on or around September 26, 2015)

New urxvt terminals do not launch, this includes tabs that'd be started via the urxvt perl extension (the extension / plugin is called "tabbed"). I have to `killall urxvtd`  to get it working again.

Let me know if there's any more debug information I could provide

$ echo $TERM
xterm

$ freebsd-version -ku; uname -apKU                                                                                                                        
11.0-CURRENT
11.0-CURRENT
FreeBSD z600 11.0-CURRENT FreeBSD 11.0-CURRENT #20: Sun Sep 27 12:29:40 CDT 2015     root@z600:/usr/obj/usr/src/sys/MYKERNEL  amd64 amd64 1100079 1100079

$ pkg info rxvt-unicode
rxvt-unicode-9.21
Name           : rxvt-unicode
Version        : 9.21
Installed on   : Sun Sep  6 20:41:23 CDT 2015
Origin         : x11/rxvt-unicode
Architecture   : freebsd:11:x86:64

$ cat ~/.Xresources

URxvt.letterSpace:      0

URxvt*intensityStyles: false
URxvt*internalBorder: 0

URxvt.inputMethod: fcitx
URxvt.preeditType: OverTheSpot

URxvt*scrollBar_right: false
URxvt*scrollBar: false

URxvt.perl-ext-common: default,matcher,tabbed
URxvt.tabbed.tabbar-bg: -1
URxvt.scrollBar:        false
URxvt.urgentOnBell:     true
URxvt.imLocale:         en_US.UTF-8
URxvt.cursorBlink:      true


URxvt.borderless:       true
URxvt*perl-ext-common:  default,matcher
URxvt*urlLauncher:      x-www-browser
URxvt*matcher.button:   1
URxvt.searchable-scrollback: CM-s
Comment 1 Tony Narlock 2015-09-28 15:09:25 UTC
I have not isolated what exactly prompts the terminal to stop responding. After using it for a while it happens.  I will pay more attention to see if I can provide more detail what specifically triggers it.

If there's any more environment information I can provide let me know and I will follow up  also.
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2015-09-28 18:32:43 UTC
*** Bug 203415 has been marked as a duplicate of this bug. ***
Comment 3 Thierry Thomas freebsd_committer 2015-10-24 16:17:09 UTC
Any news about this problem? I have not seen any similar report...

May be you could also provide the output of `pkg info perl5'
and a script of a truss output:

script /tmp/urxvt.out
truss /usr/local/bin/urxvt -letsp -1 -pe digital-clock,tabbed &
[some activity in urxvt]
^D
bzip2 -9 /tmp/urxvt.out
Comment 4 Tony Narlock 2017-01-16 10:54:37 UTC
We can close this, I haven't had this happen since.