Bug 203451 - archivers/snappy: snappy-1.1.3 won't compile
Summary: archivers/snappy: snappy-1.1.3 won't compile
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Vanilla I. Shu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-30 12:05 UTC by Dušan Vejnovič
Modified: 2015-09-30 15:06 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (vanilla)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dušan Vejnovič 2015-09-30 12:05:54 UTC
with poudriere I got this error:

he first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   snappy-1.1.3 depends on executable: autoconf-2.69 - found
===>   Returning to build of snappy-1.1.3
===>   snappy-1.1.3 depends on executable: autoheader-2.69 - found
===>   snappy-1.1.3 depends on executable: autoreconf-2.69 - found
===>   snappy-1.1.3 depends on executable: aclocal-1.15 - not found
===>   Installing existing package /packages/All/automake-1.15.txz
[mars-default-job-03] Installing automake-1.15...
[mars-default-job-03] `-- Installing automake-wrapper-20131203...
[mars-default-job-03] `-- Extracting automake-wrapper-20131203: ... done
[mars-default-job-03] Extracting automake-1.15: .......... done
===>   snappy-1.1.3 depends on executable: aclocal-1.15 - found
===>   Returning to build of snappy-1.1.3
===>   snappy-1.1.3 depends on executable: automake-1.15 - found
===>   snappy-1.1.3 depends on executable: libtoolize - not found
===>   Installing existing package /packages/All/libtool-2.4.6.txz
[mars-default-job-03] Installing libtool-2.4.6...
[mars-default-job-03] Extracting libtool-2.4.6: .......... done
===>   snappy-1.1.3 depends on executable: libtoolize - found
===>   Returning to build of snappy-1.1.3
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for snappy-1.1.3
libtoolize: putting auxiliary files in '.'.
libtoolize: copying file './ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIRS, 'm4'.
libtoolize: copying file 'm4/libtool.m4'
libtoolize: copying file 'm4/ltoptions.m4'
libtoolize: copying file 'm4/ltsugar.m4'
libtoolize: copying file 'm4/ltversion.m4'
libtoolize: copying file 'm4/lt~obsolete.m4'
configure.ac:42: error: possibly undefined macro: AC_DEFINE
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.ac:44: error: possibly undefined macro: AC_MSG_FAILURE
autoreconf-2.69: /usr/local/bin/autoconf-2.69 failed with exit status: 1
*** Error code 1
Comment 1 Steve Wills freebsd_committer 2015-09-30 13:28:27 UTC
Needs pkgconfig added to USES. Shall I commit?
Comment 2 Dušan Vejnovič 2015-09-30 13:55:42 UTC
(In reply to Steve Wills from comment #1)

Yes, please.
Comment 3 Vanilla I. Shu freebsd_committer 2015-09-30 14:07:34 UTC
Sure, please
Comment 4 commit-hook freebsd_committer 2015-09-30 15:04:40 UTC
A commit references this bug:

Author: swills
Date: Wed Sep 30 15:04:23 UTC 2015
New revision: 398217
URL: https://svnweb.freebsd.org/changeset/ports/398217

Log:
  archivers/snappy: fix build

  PR:		203451
  Reported by:	Dusan Vejnovic <freebsd@dussan.org>
  Approved by:	vanilla (maintianer)

Changes:
  head/archivers/snappy/Makefile
Comment 5 Steve Wills freebsd_committer 2015-09-30 15:06:06 UTC
Committed!