Bug 203537 - [PATCH] graphics/graphviz: Enable NVTHREADS by default
Summary: [PATCH] graphics/graphviz: Enable NVTHREADS by default
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords: patch
: 203968 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-10-04 16:03 UTC by Tobias Kortkamp
Modified: 2015-10-29 06:21 UTC (History)
1 user (show)

See Also:
dinoex: maintainer-feedback-


Attachments
graphviz.diff (720 bytes, patch)
2015-10-04 16:03 UTC, Tobias Kortkamp
no flags Details | Diff
Poudriere log (260.06 KB, text/x-log)
2015-10-04 16:04 UTC, Tobias Kortkamp
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Kortkamp freebsd_committer 2015-10-04 16:03:23 UTC
Created attachment 161702 [details]
graphviz.diff

Currently installing Graphviz via pkg on a FreeBSD 10.2 system with x11/nvidia-driver installed fails with:

[1/1] Extracting graphviz-2.38.0_9: 100%
Unable to find pthread_mutexattr_setkind_np versioned symbol. Aborting.
Abort trap (core dumped)

Graphviz is unusable afterwards. Recompiling Graphviz with the NVTHREADS option fixes this. Also see bug #171949. 

Can we enable NVTHREADS by default? AFAICT Graphviz with NVTHREADS will work fine even on non-NVIDIA systems. Are there any downsides to enabling this by default?
Comment 1 Tobias Kortkamp freebsd_committer 2015-10-04 16:04:07 UTC
Created attachment 161703 [details]
Poudriere log
Comment 2 Dirk Meyer freebsd_committer 2015-10-13 18:48:59 UTC
The downside of this will be that each ports that depends of graphviz must be compiled and linked with threads.

with NVIDIA users threads are linked in by the X*libs provided.
for non NVIDIA systems I expect lost of ports to fail.

Testbuilds are needed.
Comment 3 commit-hook freebsd_committer 2015-10-29 06:13:15 UTC
A commit references this bug:

Author: dinoex
Date: Thu Oct 29 06:12:51 UTC 2015
New revision: 400442
URL: https://svnweb.freebsd.org/changeset/ports/400442

Log:
  - make option NVTHREADS default
  PR:		203537
  Submitted by:	Tobias Kortkamp

Changes:
  head/graphics/graphviz/Makefile
Comment 4 Dirk Meyer freebsd_committer 2015-10-29 06:21:32 UTC
*** Bug 203968 has been marked as a duplicate of this bug. ***