Bug 203672 - [devel/autogen] Fixed bash shebang in autogen (very easy)
Summary: [devel/autogen] Fixed bash shebang in autogen (very easy)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: John Marino
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-10 01:53 UTC by Yuri Victorovich
Modified: 2015-10-16 21:26 UTC (History)
1 user (show)

See Also:


Attachments
patch (686 bytes, patch)
2015-10-10 01:53 UTC, Yuri Victorovich
no flags Details | Diff
poudriere log (70.35 KB, text/plain)
2015-10-10 06:00 UTC, Yuri Victorovich
no flags Details
Updated patch (1.04 KB, patch)
2015-10-16 19:40 UTC, Yuri Victorovich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2015-10-10 01:53:21 UTC
Created attachment 161867 [details]
patch

The attached patch fixes the build problem (failure message suggests to add the shebang location).
Comment 1 Yuri Victorovich freebsd_committer 2015-10-10 06:00:16 UTC
Created attachment 161869 [details]
poudriere log
Comment 2 John Marino freebsd_committer 2015-10-16 18:48:33 UTC
You haven't explained the problem.  (you mention "the build problem" but haven't established what the problem is).

Secondly, you're referencing bash but I don't see any build depends or run depends on bash.

I'm afraid the introduction to this PR is lacking.

e.g. 
1. what's the problem
2. suggestioned solution (the patch)
3. explain why the patch solves the problem
4. impact of not applying the patch (i.e. rejecting the solution)

The portmon is all green lights so I'm not sure what this problem is.
Comment 3 John Marino freebsd_committer 2015-10-16 18:58:08 UTC
ah, i see the build depends on bash now.  I missed that at first.

still, what build error are we trying to solve and what happens as a result of this error?
Comment 4 Yuri Victorovich freebsd_committer 2015-10-16 19:00:50 UTC
Sorry I didn't properly explain the problem in the OP.

Here is the build error log I am getting:
> ====> Compressing man pages (compress-man)
> ====> Running Q/A tests (stage-qa)
> Error: '/bin/bash' is an invalid shebang you need USES=shebangfix for 'bin/autoopts-config'
> *** Error code 1

The port already has bash as a runtime dependency.

I am not sure why you aren't seeing the same error, because work/autogen-5.18.4/autoopts/autoopts-config does have the wrong shebang in it.

10.2-STABLE
Comment 5 John Marino freebsd_committer 2015-10-16 19:04:56 UTC
so why are you expecting anyone that peruses this PR to be aware of a stage QA error?   How would we know this?  Other than building the port in poudriere with full testing, check the log, and then look back at the PR.

I would have pasted that excerpt of the log into the PR.

These stage-QA errors don't break standard builds because they are extra testing that isn't done on the cluster.
Comment 6 John Marino freebsd_committer 2015-10-16 19:06:27 UTC
btw, bash is NOT a run depends.

Should it be?  Is this autoopts-config script a core executable?  if so, bash should be a run depends.
Comment 7 Yuri Victorovich freebsd_committer 2015-10-16 19:10:18 UTC
I got the error through the simple 'make' command. Not sure why stage-qa runs through the make command for me.

But it isn't an entirely bad idea to build in poudriere with stage QA.

> I would have pasted that excerpt of the log into the PR.

I just did, didn't I?
Comment 8 John Marino freebsd_committer 2015-10-16 19:13:25 UTC
more explicit phrasing:

"I would have pasted an excerpt of the log in the description of the PR to establish the problem".

It's not happening to everyone because stage-qa is not run by default.  you must have developer mode or something that is triggering it.

the missing run-depends (if it's missing) will require a new patch.
Comment 9 Yuri Victorovich freebsd_committer 2015-10-16 19:15:31 UTC
> btw, bash is NOT a run depends.

> Should it be?  Is this autoopts-config script a core executable?  if so, bash should be a run depends.

I am not particularly familiar with autogen, but I don't see any installed by it exacutables using bash. So why would it need to be the runtime dependency?


Ah yes, I had developer mode "on", that's why I even got the error.

So no it is all clear, right?
Comment 10 Yuri Victorovich freebsd_committer 2015-10-16 19:16:43 UTC
Ah, okay, it does need runtime dep.

I will re-submit the patch
Comment 11 Yuri Victorovich freebsd_committer 2015-10-16 19:40:12 UTC
Created attachment 162130 [details]
Updated patch

Updated patch addresses these issues:

1. It fixes the above-mentioned shebang problem (message during the stage QA)
2. Fixed the port comment (doesn't begin with "The" now)
3. Added the license clause
Comment 12 commit-hook freebsd_committer 2015-10-16 21:26:10 UTC
A commit references this bug:

Author: marino
Date: Fri Oct 16 21:25:36 UTC 2015
New revision: 399523
URL: https://svnweb.freebsd.org/changeset/ports/399523

Log:
  devel/autogen: Fix stage-qa failure

  The autoopts-config script needs bash, so it's been added as a run
  dependences and the shebang wsa fixed.  While here, add the GPLv2 LICENSE
  and improve the COMMENT.

  PR:		203672
  Submitted by:	Yuri (rawbw.com)

Changes:
  head/devel/autogen/Makefile
Comment 13 John Marino freebsd_committer 2015-10-16 21:26:31 UTC
thanks