Bug 203818 - games/warzone2100: crashes with emmitting weird sound
Summary: games/warzone2100: crashes with emmitting weird sound
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Dmitry Marakasov
URL:
Keywords:
Depends on: 199488
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 13:37 UTC by O. Hartmann
Modified: 2015-11-23 20:30 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (amdmi3)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2015-10-16 13:37:12 UTC
On CURRENT, port games/warzone2100 fails to run. Compilation is always good, but the software is emmitting weird, scratchy noise when starting up and then crashing, giving a error message on dying:

~ % warzone2100
info    |03:33:38: [realmain:1143] Using /home/ohartman/.warzone2100-3.1/logs/WZlog-1016_153338.txt debug file
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
A syntax error in expression, near `/m'.
Saved dump file to '/home/ohartman/.warzone2100-3.1/logs/warzone2100.gdmp-0cpNev'
If you create a bugreport regarding this crash, please include this file.
Segmentation fault
Comment 1 Dmitry Marakasov freebsd_committer 2015-10-16 14:36:33 UTC
Could it be https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=199488 ?
Comment 2 Dmitry Marakasov freebsd_committer 2015-10-16 14:37:14 UTC
(Try recompiling openal with gcc)
Comment 3 O. Hartmann 2015-10-16 18:53:15 UTC
PR 199488 provides a patch which fixes the problem. Thanks.
Comment 4 commit-hook freebsd_committer 2015-10-17 16:33:24 UTC
A commit references this bug:

Author: danilo
Date: Sat Oct 17 16:32:53 UTC 2015
New revision: 399540
URL: https://svnweb.freebsd.org/changeset/ports/399540

Log:
  - Add a workaround for a problem caused by clang

  For some reason clang is breaking the code when openal-soft is built with
  optimizations. If the file alBuffer.c is built with -O1 the problem don't
  happens. See https://github.com/kcat/openal-soft/issues/18
  The problem seems to happen just on CURRENT due the clang version.

  PR:		199488, 203818
  Tested by:	ohartman@zedat.fu-berlin.de
  Approved by:	mva
  MFH:		2015Q4

Changes:
  head/audio/openal-soft/Makefile
  head/audio/openal-soft/files/patch-OpenAL32_alBuffer.c
Comment 5 commit-hook freebsd_committer 2015-10-19 14:23:20 UTC
A commit references this bug:

Author: danilo
Date: Mon Oct 19 14:22:46 UTC 2015
New revision: 399683
URL: https://svnweb.freebsd.org/changeset/ports/399683

Log:
  MFH: r399540

  - Add a workaround for a problem caused by clang

  For some reason clang is breaking the code when openal-soft is built with
  optimizations. If the file alBuffer.c is built with -O1 the problem don't
  happens. See https://github.com/kcat/openal-soft/issues/18
  The problem seems to happen just on CURRENT due the clang version.

  PR:		199488, 203818
  Tested by:	ohartman@zedat.fu-berlin.de
  Approved by:	mva
  Approved by:	ports-secteam (feld)

Changes:
_U  branches/2015Q4/
  branches/2015Q4/audio/openal-soft/Makefile
  branches/2015Q4/audio/openal-soft/files/patch-OpenAL32_alBuffer.c
Comment 6 Dmitry Marakasov freebsd_committer 2015-11-23 20:30:22 UTC
Should be fixed in openal, not a warzone2100 problem in any case