Bug 203889 - MacBook UGA issues at login prompt.
Summary: MacBook UGA issues at login prompt.
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-20 10:37 UTC by David O'Rourke
Modified: 2018-05-16 15:22 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David O'Rourke 2015-10-20 10:37:54 UTC
This bug is probably related to bug #202730.

I've recently been playing with FreeBSD 11-CURRENT on a 2009 MacBook Pro, since the work in #202730 allowed me to UEFI boot on that machine.

Everything was fine for a while.

However, when the machine is now booted, everything is OK and output is fine until the screen is cleared for the login prompt (does it reset the graphics mode here?), at which time it looks like the kernel has forgotten what the "stride" is.

This issue started after I put the machine into S3 sleep by closing the lid. After I woke the machine the screen was blank and I had to reboot (pushed power button for clean shutdown since nothing was displayed).

After that, the login prompt would always look like the stride was broken again. Rebooting/powering down and booting an older FreeBSD 11 kernel all exhibit the same issue.

Perhaps the UGA/UEFI/framebuffer are stuck in a strange state that isn't cleared on boot?

I haven't yet tried detaching the battery from the MBP to let it truly power down.

Please let me know if there are more details that I can provide (there probably are). I should be able to SSH into the machine to examine it in its broken state.

Cheers,
Comment 1 David O'Rourke 2015-10-22 09:05:38 UTC
I have now worked out what was happening here. I'd forgotten that I had installed "Slim" and enabled it before heading to sleep that evening.

So, when the machine booted, everything was fine. Slim was attempting to start, failing, and being returned to the console (vt).

There is still an issue here. The stride was being lost after Slim failed to start (three fuzzy columns across the screen similar to bug #202730) and now that I do have a working Xorg setup, it is not possible to return to the console after being in X (consoles all blank).

Cheers,
Comment 2 David O'Rourke 2018-05-16 15:22:40 UTC
Closing as it's been a while and I'm unsure whether this is still an issue or not.
I don't remember having such issues last time I used the hardware.