Bug 203890 - devel/llvm37 unable to apply patches on FreeBSD 9.x
Summary: devel/llvm37 unable to apply patches on FreeBSD 9.x
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Brooks Davis
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-20 10:41 UTC by luca.pizzamiglio
Modified: 2015-10-21 16:36 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (brooks)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description luca.pizzamiglio 2015-10-20 10:41:22 UTC
On FreeBSD 9 the new lldb patches fails to apply.
The tools/lldb directory is missing, because OPSYS is FreeBSD and COMPILER_TYPE is gcc (as default).

Don't know if the patch shouldn't be applied in this case or the directory should be created in any case.

Configuration:
===> The following configuration options are available for llvm37-3.7.0_4:
     CLANG=on: Build clang
     COMPILER_RT=on: Build compiler-rt (sanitizers)
     DOCS=on: Build and/or install documentation
     EXTRAS=on: Extra clang tools
     GOLD=on: Build the LLVM Gold plugin for LTO
     LIT=on: Install lit and FileCheck test tools
     LLD=on: Install lld, the LLVM linker
     LLDB=on: Install lldb, the LLVM debugger (ignored on 9.x)
     OPENMP=on: Install libomp, the LLVM OpenMP runtime library

uname -r 9.3-RELEASE-p24
Comment 1 luca.pizzamiglio 2015-10-20 11:28:41 UTC
I guess I have to rephrase my previous comment with:

'lldb patches are applied on FreeBSD 9 instead to be ignored'
Comment 2 Brooks Davis freebsd_committer 2015-10-20 17:25:06 UTC
The patches indeed shouldn't be applied in this case.  I'll get this fixed.  Thanks for the report.
Comment 3 commit-hook freebsd_committer 2015-10-20 23:13:58 UTC
A commit references this bug:

Author: brooks
Date: Tue Oct 20 23:13:27 UTC 2015
New revision: 399882
URL: https://svnweb.freebsd.org/changeset/ports/399882

Log:
  Only apply the LLDB packages if we're going to build it.

  PR:		203890

Changes:
  head/devel/llvm37/Makefile
Comment 4 Laurence 'GreenReaper' Parry 2015-10-21 00:50:04 UTC
(In reply to commit-hook from comment #3)
I'm getting this when I compile llvm37-3.7.0_4 with LLD but not LLDB:

===>  Applying extra patch /usr/ports/devel/llvm37/files/lldb-patch-svn-247116
File to patch:
No file found--skip this patch? [n] y
2 out of 2 hunks ignored--saving rejects to Oops.rej
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/llvm37


Perhaps the problem is that you used this:
.if ${PORT_OPTIONS:MLLD}

rather than this?
.if ${PORT_OPTIONS:MLLDB}

https://svnweb.freebsd.org/ports/head/devel/llvm37/Makefile?r1=399795&r2=399882&pathrev=399882
Comment 5 commit-hook freebsd_committer 2015-10-21 16:36:31 UTC
A commit references this bug:

Author: brooks
Date: Wed Oct 21 16:36:07 UTC 2015
New revision: 399925
URL: https://svnweb.freebsd.org/changeset/ports/399925

Log:
  Fix building LLD without LLDB by applying LLDB patches in the right case.

  PR:		203890
  Submitted by:	Laurence 'GreenReaper' Parry <greenreaper@hotmail.com>

Changes:
  head/devel/llvm37/Makefile