Bug 203930 - net-mgmt/ccnet: Update to 5.1.1
Summary: net-mgmt/ccnet: Update to 5.1.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Dmitry Marakasov
URL:
Keywords: easy, patch, patch-ready
: 208799 (view as bug list)
Depends on: 204102
Blocks: 203933
  Show dependency treegraph
 
Reported: 2015-10-21 15:09 UTC by Ultima
Modified: 2016-09-05 16:25 UTC (History)
5 users (show)

See Also:
Ultima1252: maintainer-feedback+


Attachments
ccnet.diff (1.93 KB, patch)
2015-10-21 15:09 UTC, Ultima
no flags Details | Diff
102amd64-poudriere.log (207.08 KB, text/x-log)
2015-10-21 20:20 UTC, Ultima
no flags Details
102i386-poudriere.log (207.08 KB, text/x-log)
2015-10-21 20:20 UTC, Ultima
no flags Details
93amd64-poudriere.log (209.28 KB, text/x-log)
2015-10-21 20:20 UTC, Ultima
no flags Details
93i386-poudriere.log (205.64 KB, text/x-log)
2015-10-21 20:21 UTC, Ultima
no flags Details
ccnet.diff (1.93 KB, patch)
2015-11-26 15:04 UTC, Ultima
Ultima1252: maintainer-approval+
Details | Diff
ccnet.diff (8.80 KB, patch)
2015-12-08 04:35 UTC, Ultima
Ultima1252: maintainer-approval+
Details | Diff
ccnet.diff (8.37 KB, patch)
2015-12-29 07:09 UTC, Ultima
Ultima1252: maintainer-approval+
Details | Diff
ccnet.diff (8.37 KB, patch)
2016-01-29 22:18 UTC, Ultima
Ultima1252: maintainer-approval+
Details | Diff
ccnet.diff (8.73 KB, patch)
2016-02-23 13:05 UTC, Ultima
Ultima1252: maintainer-approval+
Details | Diff
ccnet.diff (8.91 KB, patch)
2016-04-14 18:13 UTC, Ultima
Ultima1252: maintainer-approval+
Details | Diff
ccnet.diff (9.08 KB, patch)
2016-04-16 22:57 UTC, Ultima
Ultima1252: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ultima 2015-10-21 15:09:56 UTC
Created attachment 162292 [details]
ccnet.diff

Another depend to the Seafile stack that needed to updated.

* Updated to 4.4.3
* Added LICENCE_FILE
* Sorted USES (for portlint)
* Added SHEBANGFIX
* Added Indentation for readability

https://reviews.freebsd.org/D3948
Comment 1 Ultima 2015-10-21 20:20:23 UTC
Created attachment 162320 [details]
102amd64-poudriere.log
Comment 2 Ultima 2015-10-21 20:20:38 UTC
Created attachment 162321 [details]
102i386-poudriere.log
Comment 3 Ultima 2015-10-21 20:20:54 UTC
Created attachment 162322 [details]
93amd64-poudriere.log
Comment 4 Ultima 2015-10-21 20:21:10 UTC
Created attachment 162323 [details]
93i386-poudriere.log
Comment 5 Jason Unovitch freebsd_committer 2015-10-29 03:23:43 UTC
Set maintainer-feedback+ as submitter is now maintainer and this is ready for QA and commit.
Comment 6 Jason Unovitch freebsd_committer 2015-10-30 02:35:02 UTC
Add depends on bug 204102 to have the audit trail on why the maintainer-feedback was reset.

See also: https://lists.FreeBSD.org/pipermail/freebsd-ports/2015-October/100923.html
Comment 7 Ultima 2015-11-26 15:04:01 UTC
Created attachment 163549 [details]
ccnet.diff

* Updated to 4.4.6
* Added LICENCE_FILE
* Sorted USES (for portlint)
* Added SHEBANGFIX
* Added Indentation for readability
Comment 8 Ultima 2015-12-08 04:35:35 UTC
Created attachment 163973 [details]
ccnet.diff

* Updated to 5.0.2
* Added LICENCE_FILE
* Sorted USES for portlint
* Regenerated patches for portlint


portlint -A:
WARN: Makefile: for new port, make $FreeBSD$ tag in comment section empty, to make SVN happy.
0 fatal errors and 1 warning found.

false positive

poudriere -t -C:
Builds fine on 102amd64, 102i386, 93amd64, 93i386

Testing:

I am currently using this in production and have created many jails to test this patch.



This patch  needs to be pushed with PR 203929 203933 203934 and 205122 205123
Comment 9 Ultima 2015-12-29 07:09:48 UTC
Created attachment 164806 [details]
ccnet.diff
Comment 10 Ultima 2016-01-29 22:18:34 UTC
Created attachment 166284 [details]
ccnet.diff

* Updated to 5.0.5

portlint -AC:
WARN: Makefile: for new port, make $FreeBSD$ tag in comment section empty, to make SVN happy.

poudriere bulk -Ct:
102amd64: ok
102i386: ok
93amd64: ok
93i386: ok
Comment 11 Kurt Jaeger freebsd_committer 2016-02-06 16:20:15 UTC
I am testbuilding right now. Would it also work with mvn33 ?
Comment 12 Kurt Jaeger freebsd_committer 2016-02-06 17:03:10 UTC
(In reply to Kurt Jaeger from comment #11)
The last reply was for a different PR, sorry.
Comment 13 Ultima 2016-02-23 13:05:53 UTC
Created attachment 167327 [details]
ccnet.diff

After r295435 on head, ccnet nolonger builds because P_KTHREAD was changed to P_KPROG, Added if for this change.


What all was added?

* P_KTHREAD --> P_KPROG
Comment 14 Dmitry Marakasov freebsd_committer 2016-04-14 15:15:55 UTC
*** Bug 208799 has been marked as a duplicate of this bug. ***
Comment 15 Dmitry Marakasov freebsd_committer 2016-04-14 15:16:14 UTC
Martin, are you going to commit this?
Comment 16 Dmitry Marakasov freebsd_committer 2016-04-14 15:20:33 UTC
Also I think ${OSVERSION} check also needs ${OPSYS} check, e.g. .if ${OPSYS} == FreeBSD && ${OSVERSION} >= ...
Comment 17 Ultima 2016-04-14 18:13:21 UTC
Created attachment 169318 [details]
ccnet.diff

(In reply to Dmitry Marakasov from comment #16)
 The check is already in the patchfile, but I decided that ill just use you're patchfile.
Comment 18 Ultima 2016-04-16 22:57:00 UTC
Created attachment 169387 [details]
ccnet.diff

* Updated to 5.1.1
Comment 19 commit-hook freebsd_committer 2016-04-17 10:35:11 UTC
A commit references this bug:

Author: amdmi3
Date: Sun Apr 17 10:34:59 UTC 2016
New revision: 413504
URL: https://svnweb.freebsd.org/changeset/ports/413504

Log:
  - Update to 5.1.1
  - Added LICENCE_FILE
  - Sorted USES for portlint
  - Regenerated patches for portlint

  PR:		203930
  Submitted by:	Ultima1252@gmail.com  (maintainer)

Changes:
  head/net-mgmt/ccnet/Makefile
  head/net-mgmt/ccnet/distinfo
  head/net-mgmt/ccnet/files/patch-Makefile.am
  head/net-mgmt/ccnet/files/patch-configure.ac
  head/net-mgmt/ccnet/files/patch-lib_Makefile.am
  head/net-mgmt/ccnet/files/patch-lib_net.c
  head/net-mgmt/ccnet/files/patch-lib_utils.c
  head/net-mgmt/ccnet/files/patch-net_common_getgateway.c
  head/net-mgmt/ccnet/pkg-plist