Bug 204154 - /usr/tests/usr.sbin/{lastcomm,sa}/legacy_test fails on arm64 -- missing MD input files
Summary: /usr/tests/usr.sbin/{lastcomm,sa}/legacy_test fails on arm64 -- missing MD in...
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: tests (show other bugs)
Version: CURRENT
Hardware: arm64 Any
: --- Affects Only Me
Assignee: Alan Somers
URL:
Keywords:
: 210565 (view as bug list)
Depends on:
Blocks: 203349
  Show dependency treegraph
 
Reported: 2015-10-30 17:18 UTC by Ed Maste
Modified: 2016-07-12 22:55 UTC (History)
2 users (show)

See Also:
asomers: mfc-stable10+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Maste freebsd_committer 2015-10-30 17:18:28 UTC
stderr output below -- these tests need to be reworked to avoid needing MD files, have arm64 MD files added, or be excluded from platforms that lack MD files.




cat: /usr/tests/usr.bin/lastcomm/v1-arm64-acct.in: No such file or directory
cat: /usr/tests/usr.bin/lastcomm/v2-arm64-acct.in: No such file or directory
cat: /usr/tests/usr.bin/lastcomm/v2-arm64.out: No such file or directory
cat: /usr/tests/usr.bin/lastcomm/v1-arm64.out: No such file or directory
lastcomm: could not open /usr/tests/usr.bin/lastcomm/v1-arm64-acct.in: No such file or directory
diff: /usr/tests/usr.bin/lastcomm/v1-arm64.out: No such file or directory
/usr/tests/usr.bin/lastcomm/legacy_test: cannot open /usr/tests/usr.bin/lastcomm/v1-arm64-acct.in: No such file or directory
diff: /usr/tests/usr.bin/lastcomm/v1-arm64.out: No such file or directory
lastcomm: could not open /usr/tests/usr.bin/lastcomm/v2-arm64-acct.in: No such file or directory
diff: /usr/tests/usr.bin/lastcomm/v2-arm64.out: No such file or directory
/usr/tests/usr.bin/lastcomm/legacy_test: cannot open /usr/tests/usr.bin/lastcomm/v2-arm64-acct.in: No such file or directory
diff: /usr/tests/usr.bin/lastcomm/v2-arm64.out: No such file or directory



install: /usr/tests/usr.sbin/sa/../../usr.bin/lastcomm/v1-arm64-acct.in: No such file or directory
install: /usr/tests/usr.sbin/sa/../../usr.bin/lastcomm/v2-arm64-acct.in: No such file or directory
diff: /usr/tests/usr.sbin/sa/v1-arm64-u.out: No such file or directory
sa: open v1-arm64-acct.in read-only: No such file or directory
sa: open v2-arm64-acct.in read-only: No such file or directory
diff: /usr/tests/usr.sbin/sa/v2-arm64-u.out: No such file or directory
sa: open v1-arm64-acct.in read-only: No such file or directory
diff: /usr/tests/usr.sbin/sa/v1-arm64-sav.out: No such file or directory
sa: open v1-arm64-acct.in read-only: No such file or directory
diff: /usr/tests/usr.sbin/sa/v1-arm64-usr.out: No such file or directory
diff: /usr/tests/usr.sbin/sa/v1-arm64-sav.out: No such file or directory
diff: /usr/tests/usr.sbin/sa/v1-arm64-usr.out: No such file or directory
install: /usr/tests/usr.sbin/sa/v1-arm64-sav.in: No such file or directory
install: /usr/tests/usr.sbin/sa/v1-arm64-usr.in: No such file or directory
diff: /usr/tests/usr.sbin/sa/v1-arm64-sav.out: No such file or directory
diff: /usr/tests/usr.sbin/sa/v1-arm64-usr.out: No such file or directory
diff: /usr/tests/usr.sbin/sa/v1-arm64-sav.out: No such file or directory
diff: /usr/tests/usr.sbin/sa/v1-arm64-usr.out: No such file or directory
sa: open v1-arm64-acct.in for read/write: No such file or directory
diff: /usr/tests/usr.sbin/sa/v1-arm64-sav.out: No such file or directory
diff: /usr/tests/usr.sbin/sa/v1-arm64-usr.out: No such file or directory
install: /usr/tests/usr.sbin/sa/../../usr.bin/lastcomm/v1-arm64-acct.in: No such file or directory
sa: open v1-arm64-acct.in for read/write: No such file or directory
install: /usr/tests/usr.sbin/sa/../../usr.bin/lastcomm/v1-arm64-acct.in: No such file or directory
sa: open v1-arm64-acct.in for read/write: No such file or directory
cp: /usr/tests/usr.sbin/sa/../../usr.bin/lastcomm/v1-arm64-acct.in: No such file or directory
sa: open v1-arm64-acct.in read-only: No such file or directory
sa: open v1-arm64-acct.in read-only: No such file or directory
Comment 1 Alan Somers freebsd_committer 2016-06-25 15:25:47 UTC
*** Bug 210565 has been marked as a duplicate of this bug. ***
Comment 2 commit-hook freebsd_committer 2016-06-26 00:53:52 UTC
A commit references this bug:

Author: asomers
Date: Sun Jun 26 00:53:31 UTC 2016
New revision: 302206
URL: https://svnweb.freebsd.org/changeset/base/302206

Log:
  Skip lastcomm and sa tests on unsupported architectures

  usr.bin/lastcom/tests/Makefile
  usr.sbin/sa/tests/Makefile
  	Set allow_architectures appropriately.  These tests depend on golden
  	files that must be generated for each architecture, and haven't yet
  	been generated for all of them.

  PR:		210566
  PR:		204154
  Reviewed by:	ngie
  Approved by:	re (gjb)
  MFC after:	4 weeks
  Sponsored by:	Spectra Logic Corp
  Differential Revision:	https://reviews.freebsd.org/D6960

Changes:
  head/usr.bin/lastcomm/tests/Makefile
  head/usr.sbin/sa/tests/Makefile
Comment 3 commit-hook freebsd_committer 2016-07-12 22:54:13 UTC
A commit references this bug:

Author: asomers
Date: Tue Jul 12 22:53:11 UTC 2016
New revision: 302689
URL: https://svnweb.freebsd.org/changeset/base/302689

Log:
  MFC r302206

  Skip lastcomm and sa tests on unsupported architectures

  usr.bin/lastcom/tests/Makefile
  usr.sbin/sa/tests/Makefile
  	Set allow_architectures appropriately.  These tests depend on
  	golden files that must be generated for each architecture, and
  	haven't yet been generated for all of them.

  PR:		204154

Changes:
_U  stable/10/
  stable/10/usr.bin/lastcomm/tests/Makefile
  stable/10/usr.sbin/sa/tests/Makefile