Bug 204223 - science/mcstas: Update to 2.2a
Summary: science/mcstas: Update to 2.2a
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jason Unovitch
URL:
Keywords: patch
Depends on:
Blocks: 204224
  Show dependency treegraph
 
Reported: 2015-11-02 13:31 UTC by Erik B Knudsen
Modified: 2015-11-12 02:37 UTC (History)
1 user (show)

See Also:


Attachments
science/mcstas new organization of ports and version upgrade diff (8.90 KB, patch)
2015-11-02 13:31 UTC, Erik B Knudsen
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Erik B Knudsen 2015-11-02 13:31:37 UTC
Created attachment 162705 [details]
science/mcstas new organization of ports and version upgrade diff

upgrade to version 2.2a

simplifications to the Makefile
Comment 1 commit-hook freebsd_committer 2015-11-12 02:30:28 UTC
A commit references this bug:

Author: junovitch
Date: Thu Nov 12 02:30:00 UTC 2015
New revision: 401313
URL: https://svnweb.freebsd.org/changeset/ports/401313

Log:
  science/mcstats[-comps]: update 2.1 -> 2.2a

  - Update PORTVERSION and distinfo to 2.2a
  - Simplify DISTNAME/DISTFILES/MASTER_SITES/WRKSRC handling
  - Clean up language in COMMENT (mcstas-comps only)
  - Use PORTVERSION in PLIST_SUB and %%PORTVERSION%% in pkg-plist as
    as port installs self-contained under ${PREFIX}/mcstas/${PORTVERSION}
  - Add pkg-install/pkg-install to SUB_FILES and rename appropriately
  - Use PREFIX in pkg-install.in/pkg-deinstall.in
  - Remove the post-fetch routines
  - Switch unnecessary bsd.port.(pre|post).mk include to just bsd.port.mk
  - Sync pkg-descr verbiage between ports and wrap at 76 characters

  PR:		204223
  PR:		204224
  Submitted by:	Erik B Knudsen <erkn@fysik.dtu.dk> (maintainer)

Changes:
  head/science/mcstas/Makefile
  head/science/mcstas/distinfo
  head/science/mcstas/files/
  head/science/mcstas/files/pkg-deinstall.in
  head/science/mcstas/files/pkg-install.in
  head/science/mcstas/pkg-deinstall
  head/science/mcstas/pkg-descr
  head/science/mcstas/pkg-install
  head/science/mcstas/pkg-plist
  head/science/mcstas-comps/Makefile
  head/science/mcstas-comps/distinfo
  head/science/mcstas-comps/pkg-descr
  head/science/mcstas-comps/pkg-plist
Comment 2 Jason Unovitch freebsd_committer 2015-11-12 02:37:15 UTC
Erik,

Comments:
1. dir -> dirrmtry in the pkg-plist was not committed.  This is deprecated and the Poudriere QA error shows this.

pkg-static: Warning: @dirrm[try] is deprecated, please use @dir

2. The superfluous space changes was not accepted.  This clutters figuring out what really changed in a diff.

It was this:
LICENSE=<space><tab>GPLv2

Rather than:
LICENSE=<tab>GPLv2

3. The post-stage was left in for the strip QA error:
Warning: 'mcstas/2.2a/bin/mcstas' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'mcstas/2.2a/bin/mcformat' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}

4. Notice how PORTVERSION is used in the final commit.  This will make things easier for you to maintain since the version number isn't hard coded in the pkg-plist or Makefile.

5. Portlint showed QA errors regarding /usr/local being hard coded.  This was fixed by renaming the pkg-install and pkg-deinstall scripts and using them in SUB_FILES.


Lastly this port doesn't integrate cleanly either before or after this change.  On the next revision can you see about getting it to install cleanly under hier(7)?  At a minimum this is the cause of portlint errors about man pages for the moment.