Bug 204265 - Add fallback PSCI reboot to cpu_reset.
Summary: Add fallback PSCI reboot to cpu_reset.
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: arm64 Any
: --- Affects Only Me
Assignee: Andrew Turner
URL:
Keywords:
: 211551 (view as bug list)
Depends on:
Blocks: 203349
  Show dependency treegraph
 
Reported: 2015-11-03 19:02 UTC by Ed Maste
Modified: 2017-06-27 10:51 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Maste freebsd_committer 2015-11-03 19:02:29 UTC
KDB: enter: panic
[ thread pid 0 tid 100953 ]
Stopped at      kdb_enter+0x40:
db> reboot
cpu_reset

[hang]
Comment 1 Andrew Turner freebsd_committer 2015-11-04 11:16:09 UTC
We need to retry PSCI reboot in cpu_reset.
Comment 2 Andrew Turner freebsd_committer 2016-08-03 17:41:20 UTC
*** Bug 211551 has been marked as a duplicate of this bug. ***
Comment 3 Ed Maste freebsd_committer 2017-06-16 14:12:36 UTC
Andy this is now fixed?
Comment 4 Andrew Turner freebsd_committer 2017-06-27 10:51:12 UTC
Fixed in head and 11.