Bug 204275 - Upgrade to latest x11-servers/xorg-server 1.17.4 and have a black screen on applications after awhile.
Summary: Upgrade to latest x11-servers/xorg-server 1.17.4 and have a black screen on a...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-04 04:05 UTC by claudius
Modified: 2017-08-14 00:47 UTC (History)
2 users (show)

See Also:


Attachments
Printscreen before black screen (345.37 KB, image/png)
2015-11-04 04:23 UTC, claudius
no flags Details
black screen after awhile (86.56 KB, image/png)
2015-11-04 04:24 UTC, claudius
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description claudius 2015-11-04 04:05:37 UTC
Hi Freebsd x11 team,

recently I upgrade to xorg-server-1.17.4, and have black screen on the app i run such as firefox after using awhile when enable the compton composite manager

my system is x1 carbon laptop. 8gig RAM, i7 processor. 
OS: FreeBSD x1-carbon-bsd 11.0-CURRENT FreeBSD 11.0-CURRENT #0 r285346.
Desktop Env: openbox+compton.

xinitrc:
==========
/home/chan/scripts/firefox-sync &
eval $(sleep 1 && stjerm -m windows -k e -o 70 -sh /usr/local/bin/bash) &
conky &
#exec enlightenment_start -nopause
compton &  
exec openbox-session
===========

How to reproduce:
1. Login to the console and run startx
2. run firefox via stjerm.
3. browsing awhile. 
4. resizing the firefox window, and the content goes black.
5. right-click on the firefox. the menu become a black box.
Comment 1 claudius 2015-11-04 04:23:58 UTC
Created attachment 162757 [details]
Printscreen before black screen
Comment 2 claudius 2015-11-04 04:24:41 UTC
Created attachment 162758 [details]
black screen after awhile
Comment 3 claudius 2015-11-04 04:28:31 UTC
After disable the composite manager compton, the screen no longer become black.
My suspect is something related to enable composite/openGL.

My xorg.conf
=============================
Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        ModulePath   "/usr/local/lib/xorg/modules"
        FontPath     "/usr/local/lib/X11/fonts/misc/"
        FontPath     "/usr/local/lib/X11/fonts/TTF/"
        FontPath     "/usr/local/lib/X11/fonts/OTF/"
        FontPath     "/usr/local/lib/X11/fonts/Type1/"
        FontPath     "/usr/local/lib/X11/fonts/100dpi/"
        FontPath     "/usr/local/lib/X11/fonts/75dpi/"
        FontPath "/usr/local/lib/X11/fonts/dejavu/"
        FontPath "/usr/local/lib/X11/fonts/Droid/"
        FontPath "/usr/local/lib/X11/fonts/LinLibertineG/"
        FontPath "/usr/local/lib/X11/fonts/Liberation/"
        FontPath "/usr/local/lib/X11/fonts/GentiumBasic/"
        FontPath "/usr/local/lib/X11/fonts/Carlito/"
        FontPath "/usr/local/lib/X11/fonts/Caladea/"
EndSection

Section "Module"
        Load  "glx"
        Load  "freetype"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/sysmouse"
        Option      "ZAxisMapping" "4 5 6 7"
        Option      "SampleRate" "1000"
        Option      "Resolution" "2000"
##Trackpoint Scrolling
        Option     "EmulateWheel" "on" #Enable wheel emulation for the Trackpoint
        Option     "EmulateWheelButton" "2" #Use the middle button for the emulation
        Option     "YAxisMapping" "4 5" #Map trackpoint Y axis to Y axis of emulated wheel
        Option     "XAxisMapping" "6 7" #Map trackpoint X axis to X axis of emulated wheel
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"                   # [<bool>]
        #Option     "AccelMethod"               # <str>
        #Option     "Backlight"                 # <str>
        #Option     "DRI"                       # <str>
        #Option     "ColorKey"                  # <i>
        #Option     "VideoKey"                  # <i>
        #Option     "Tiling"                    # [<bool>]
        #Option     "LinearFramebuffer"         # [<bool>]
        #Option     "SwapbuffersWait"           # [<bool>]
        #Option     "TripleBuffer"              # [<bool>]
        #Option     "XvPreferOverlay"           # [<bool>]
        #Option     "HotPlug"                   # [<bool>]
        #Option     "ReprobeOutputs"            # [<bool>]
        #Option     "XvMC"                      # [<bool>]
        #Option     "ZaphodHeads"               # <str>
        #Option     "TearFree"                  # [<bool>]
        #Option     "PerCrtcPixmaps"            # [<bool>]
        #Option     "FallbackDebug"             # [<bool>]
        #Option     "DebugFlushBatches"         # [<bool>]
        #Option     "DebugFlushCaches"          # [<bool>]
        #Option     "DebugWait"                 # [<bool>]
        #Option     "BufferCache"               # [<bool>]
        Identifier  "Card0"
        Driver      "intel"
        BusID       "PCI:0:2:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
========================
Comment 4 Jean-Sébastien Pédron freebsd_committer 2015-11-04 16:44:44 UTC
Hi!

Your problem really looks like bug 204174.

Could you please try to update your libdrm from ports (or wait a couple days and for a binary package to be available) and see if it persists?
Comment 5 claudius 2015-11-05 02:42:50 UTC
hi Jean,
Thanks alot for the info. I updated the libdrm to latest from ports. It seems working fine.

Let me use it for another day and verify if the problem will occur again.

If nothing happens i will proceed to close the ticket.
Comment 6 claudius 2015-11-17 09:27:41 UTC
Looking good after 10 days of using it.Close the ticket.