Bug 204342 - [patch] www/mod_auth_mysql2: fix abi with apache24
Summary: [patch] www/mod_auth_mysql2: fix abi with apache24
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords: needs-qa, patch
Depends on:
Blocks:
 
Reported: 2015-11-06 20:13 UTC by Kurt Jaeger
Modified: 2016-02-23 08:58 UTC (History)
1 user (show)

See Also:
pi: merge-quarterly-


Attachments
patch (1.18 KB, patch)
2015-11-06 20:13 UTC, Kurt Jaeger
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kurt Jaeger freebsd_committer 2015-11-06 20:13:42 UTC
Created attachment 162858 [details]
patch

patch as suggested in

https://lists.freebsd.org/pipermail/freebsd-ports/2015-November/101011.html

Please note that

https://lists.freebsd.org/pipermail/freebsd-ports/2015-November/101013.html

suggests and explains how to use mod_dbd, which is part of the base port.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-08 08:20:44 UTC
Reporter is committer, assign accordingly.

@Kurt, no comment after setting merge-quarterly (-), can you add one please
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-08 08:21:10 UTC
Comment on attachment 162858 [details]
patch

Port is unmaintained, implicit maintainer-approval
Comment 3 Kurt Jaeger freebsd_committer 2015-11-08 08:48:10 UTC
The port is so old, it should probably be deprecated in favor of the suggested other apache module.
Comment 4 rabe 2016-02-04 22:03:10 UTC
my server is affected as well and currently I don't see any alternative because my setup depends heavily on Users/Groups/Hosts.

I'd really appreciate any fixed packages in the repo.

Regards
Raphael Eiselstein

Some more details:

# uname -srm
FreeBSD 10.2-RELEASE amd64

# service apache24 restart
Performing sanity check on apache24 configuration:
httpd: Syntax error on line 176 of /usr/local/etc/apache24/httpd.conf: Cannot load libexec/apache24/mod_auth_mysql.so into server: /usr/local/libexec/apache24/mod_auth_mysql.so: Undefined symbol "ap_requires"

# ldd /usr/local/libexec/apache24/mod_auth_mysql.so
/usr/local/libexec/apache24/mod_auth_mysql.so:
        libmysqlclient.so.18 => /usr/local/lib/mysql/libmysqlclient.so.18 (0x801800000)
        libc.so.7 => /lib/libc.so.7 (0x800821000)
        libm.so.5 => /lib/libm.so.5 (0x801de0000)
        libc++.so.1 => /usr/lib/libc++.so.1 (0x802009000)
        libcxxrt.so.1 => /lib/libcxxrt.so.1 (0x8022c8000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x8024e4000)
        libthr.so.3 => /lib/libthr.so.3 (0x8026f2000)


# pkg info ap24-mod_auth_mysql2-1.10_2
ap24-mod_auth_mysql2-1.10_2
Name           : ap24-mod_auth_mysql2
Version        : 1.10_2
Installed on   : Thu Feb  4 22:45:20 2016 CET
Origin         : www/mod_auth_mysql2
Architecture   : freebsd:10:x86:64
Prefix         : /usr/local
Categories     : www
Licenses       : APACHE20
Maintainer     : ports@FreeBSD.org
WWW            : http://www.heuer.org/mod_auth_mysql/
Comment        : MySQL-based authentication module with VirtualHost support
Shared Libs required:
        libmysqlclient.so.18
Annotations    :
        repo_type      : binary
        repository     : FreeBSD
Flat size      : 35.6KiB
Description    :
mod_auth_mysql provides an MySQL-based authentication for apache2.
It's also designed to support multiple virtualhosts using only one 
database.

WWW: http://www.heuer.org/mod_auth_mysql/
Comment 5 commit-hook freebsd_committer 2016-02-23 08:57:26 UTC
A commit references this bug:

Author: pi
Date: Tue Feb 23 08:57:14 UTC 2016
New revision: 409386
URL: https://svnweb.freebsd.org/changeset/ports/409386

Log:
  www/mod_auth_mysql2: 1.10 -> 1.11

  - Fix build with Apache 2.4

  PR:		204342

Changes:
  head/www/mod_auth_mysql2/Makefile
  head/www/mod_auth_mysql2/distinfo
Comment 6 Kurt Jaeger freebsd_committer 2016-02-23 08:58:19 UTC
Fixed upstream, updated, done.