Bug 204494 - [PATCH] sysutils/mdf2iso: mark UN'BROKEN (fetchable)
Summary: [PATCH] sysutils/mdf2iso: mark UN'BROKEN (fetchable)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords: easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2015-11-12 09:49 UTC by Matthew Rezny
Modified: 2016-01-03 21:46 UTC (History)
3 users (show)

See Also:
koobs: merge-quarterly?


Attachments
make sysutils/mdf2iso fetchable (1.59 KB, patch)
2015-11-12 09:49 UTC, Matthew Rezny
no flags Details | Diff
NEW svn diff for sysutils/mdf2iso (1.75 KB, patch)
2015-11-17 02:48 UTC, Chris Hutchinson
no flags Details | Diff
QA LOG for sysutils/mdf2iso (7.64 KB, text/plain)
2015-11-17 02:49 UTC, Chris Hutchinson
no flags Details
svn diff for sysutils/mdf2iso (1.73 KB, patch)
2015-11-21 21:25 UTC, Chris Hutchinson
no flags Details | Diff
svn diff for sysutils/mdf2iso (1.73 KB, patch)
2015-11-21 21:31 UTC, Chris Hutchinson
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Rezny freebsd_committer 2015-11-12 09:49:37 UTC
Created attachment 163044 [details]
make sysutils/mdf2iso fetchable

The minimal SF mirror of the berliOS project does not include any files. The only copy of the tar.gz I could find was in our distcache. I did find the tar.bz2 file on a couple Gentoo mirrors so switched to that. Contents of the tarballs was confirmed to be indentical before replacing the hash.
Comment 1 Chris Hutchinson 2015-11-17 02:46:14 UTC
Greetings,
I know this is a pretty trivial utility. But I still find it useful.
Given that it's future on the internet currently looks bleak. If
taken the initiative to make a new home for it, including a git(1)
repo on Gitlab.

In short; I'd like to adopt this port.

Please find attached, a svn diff that

provides a new MASTER_SITES
bumps PORTVERSION
adds MAINTAINER
updates pkg-descr

and a QA LOG! :)

Thanks!

--Chris
Comment 2 Chris Hutchinson 2015-11-17 02:48:32 UTC
Created attachment 163228 [details]
NEW svn diff for sysutils/mdf2iso

hopes to supersede previous patch
Comment 3 Chris Hutchinson 2015-11-17 02:49:59 UTC
Created attachment 163229 [details]
QA LOG for sysutils/mdf2iso

QA LOG for sysutils/mdf2iso
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-17 13:40:54 UTC
@Matthew / @Chris, thank you both for submitting changes to rescue this port. Can you organise/decide among yourselves which patch should be committed.

Since this port has no maintainer, both changes 'technically' have implicit approval, so I'm going to reset the flag until you've both decided and provide instructions.

1) Whichever way we go, we should have redundant MASTER_SITES and a 'non-fork' situation. Where did version 3.1 come from?

2) Regarding the merge (MFH) to quarterly, a separate changeset should be attached just for the fix (if it applied to the latest quarterly), as version updates don't go there (which I'm still unsure about)
Comment 5 Chris Hutchinson 2015-11-19 16:01:04 UTC
(In reply to Kubilay Kocak from comment #4)
> @Matthew / @Chris, thank you both for submitting changes to rescue this
> port. Can you organise/decide among yourselves which patch should be
> committed.
> 
> Since this port has no maintainer, both changes 'technically' have implicit
> approval, so I'm going to reset the flag until you've both decided and
> provide instructions.
> 
> 1) Whichever way we go, we should have redundant MASTER_SITES and a
> 'non-fork' situation. Where did version 3.1 come from?
> 
> 2) Regarding the merge (MFH) to quarterly, a separate changeset should be
> attached just for the fix (if it applied to the latest quarterly), as
> version updates don't go there (which I'm still unsure about)

@Kubilay
The only change to the source, was to indicate it has a new [working]
home, and provides for further development. Nothing in source was
changed to affect the functionality of the application itself. This
was what I attributed the necessity to bump the PORTVERSION.

Thanks for the reply!
Comment 6 Chris Hutchinson 2015-11-19 16:02:54 UTC
@Matthew
Any objection to my Adopting the port?

Thanks for your time.

--Chris
Comment 7 Matthew Rezny freebsd_committer 2015-11-21 01:46:57 UTC
Chris:

No objection to you adopting the port. I was happy to see someone step up and put some effort to ensuring ongoing availability of distfiles. The sources I found could disappear tomorrow.

However, I also must question the change of version. The version should reflect and actual change to the functional state of the software. Merely changing the location where a project resides is not a change to the software itself and not a reason to change the version number. Repackaging in .tar.xz with same version number as part of moving and modernizing should be no issue, bump the portrevision if needed but not portversion. Save the version bump for wen you have made a change to the software. It could probably use a bit of cleanup after all these years.
Comment 8 Chris Hutchinson 2015-11-21 02:37:10 UTC
(In reply to matthew from comment #7)
> Chris:
> 
> No objection to you adopting the port. I was happy to see someone step up
> and put some effort to ensuring ongoing availability of distfiles. The
> sources I found could disappear tomorrow.
> 
> However, I also must question the change of version. The version should
> reflect and actual change to the functional state of the software. Merely
> changing the location where a project resides is not a change to the
> software itself and not a reason to change the version number. Repackaging
> in .tar.xz with same version number as part of moving and modernizing should
> be no issue, bump the portrevision if needed but not portversion. Save the
> version bump for wen you have made a change to the software. It could
> probably use a bit of cleanup after all these years.

Good advice, Matthew.
I'll revert the PORTVERSION, and bump PORTREVISION as a better
reflection of the changes, and update the svn diff in reflection
of those changes.

Thanks, Matthew!

--Chris
Comment 9 Chris Hutchinson 2015-11-21 21:25:56 UTC
Created attachment 163388 [details]
svn diff for sysutils/mdf2iso

CURRENT patch (svn diff) for sysutils/mdf2iso
Updated as per <a href=#c7">comment 7</a>
Obsoletes all previous.

This patch adds PORTREVISION
updates MASTER_SITES, MAINTAINER, USES (tar:xz), and distinfo

This should be considered the final patch to UNBREAK sysutils/mdf2iso

Thanks!

--Chris
Comment 10 Chris Hutchinson 2015-11-21 21:31:13 UTC
Created attachment 163389 [details]
svn diff for sysutils/mdf2iso

Corrects typo in previous in distinfo
This is final -- really! ;)

Sorry for the bother!

--Chris
Comment 11 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-22 02:11:05 UTC
@Chris/Matthew, please organise/agree to bosolete one of the two attachments, so its clear to a committer what needs to (not) be referenced.

@Chris, obsoleting the current QA log, and attaching an updated QA log (or just a confirmation) would be great too.
Comment 12 Chris Hutchinson 2015-11-22 21:12:22 UTC
Comment on attachment 163229 [details]
QA LOG for sysutils/mdf2iso

This QA LOG remains applicable to my most recently submitted
<a href="https://bugs.freebsd.org/bugzilla/attachment.cgi?id=163389">patch</a>.
The source wasn't changed.
Comment 13 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-23 08:16:53 UTC
Comment on attachment 163389 [details]
svn diff for sysutils/mdf2iso

Port is unmaintained, implicit approval
Comment 14 Kurt Jaeger freebsd_committer 2015-11-23 20:28:59 UTC
The distfile does not fetch ?

=> mdf2iso-0.3.0.tar.xz doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch http://BSDforge.com/projects/source/sysutils/mdf2iso/mdf2iso-0.3.0.tar.xz
fetch: http://BSDforge.com/projects/source/sysutils/mdf2iso/mdf2iso-0.3.0.tar.xz: Not Found
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/mdf2iso-0.3.0.tar.xz
Comment 15 Chris Hutchinson 2015-11-24 01:42:54 UTC
(In reply to Kurt Jaeger from comment #14)
> The distfile does not fetch ?
> 
> => mdf2iso-0.3.0.tar.xz doesn't seem to exist in /usr/ports/distfiles/.
> => Attempting to fetch
> http://BSDforge.com/projects/source/sysutils/mdf2iso/mdf2iso-0.3.0.tar.xz
> fetch:
> http://BSDforge.com/projects/source/sysutils/mdf2iso/mdf2iso-0.3.0.tar.xz:
> Not Found
> => Attempting to fetch
> http://distcache.FreeBSD.org/ports-distfiles/mdf2iso-0.3.0.tar.xz

D'OH!
Sorry. A naming issue I forgot to deal with.
It's all fixed.

Thanks, Kurt!

--Chris
Comment 16 commit-hook freebsd_committer 2015-11-24 06:22:18 UTC
A commit references this bug:

Author: pi
Date: Tue Nov 24 06:21:17 UTC 2015
New revision: 402347
URL: https://svnweb.freebsd.org/changeset/ports/402347

Log:
  sysutils/mdf2iso: unbreak, new distsite, new maintainer, new WWW

  PR:		204494
  Submitted by:	matthew@reztek.cz, portmaster@bsdforge.com

Changes:
  head/sysutils/mdf2iso/Makefile
  head/sysutils/mdf2iso/distinfo
  head/sysutils/mdf2iso/pkg-descr
Comment 17 Kurt Jaeger freebsd_committer 2015-11-24 06:22:44 UTC
Committed, thanks.
Comment 18 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-24 06:24:59 UTC
Needs MFH or set to - if not applicable (not broken in quarterly)
Comment 19 Kurt Jaeger freebsd_committer 2016-01-03 21:46:40 UTC
merge to quarterly obsoleted by 2016q1 quarterly.