Bug 204499 - audio/ncmpcpp: Update to 0.7.0-b1
Summary: audio/ncmpcpp: Update to 0.7.0-b1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords: patch, patch-ready
Depends on:
Blocks:
 
Reported: 2015-11-12 13:49 UTC by yamagi
Modified: 2015-11-15 16:27 UTC (History)
1 user (show)

See Also:


Attachments
svn patch to version 0.7.0b1 (13.50 KB, patch)
2015-11-12 13:49 UTC, yamagi
koobs: maintainer-approval+
Details | Diff
Update to 0.7.0b1 (with DISTNAME instead fo DISTFILES) (13.49 KB, patch)
2015-11-13 10:35 UTC, yamagi
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description yamagi 2015-11-12 13:49:14 UTC
Created attachment 163053 [details]
svn patch to version 0.7.0b1

Hello,
the attached svn patch updates audio/ncmpcpp to version 0.7.0-beta1.This is a major update with several new features. A full changelog can be found at http://rybczak.net/ncmpcpp/, the most important changes are:

- Multiple colors and new modes for the visualizer
- New sort and search options
- Finally support for 256 color terminals
- Support for PCRE regex
- Several key binding options are now finer grained

I've run this beta version for several days and didn't find problems or regressions. So it seems to be stable enough for widespread distribution.

Changes to the port are:
- Remove unnecessary patches and regenerate the other ones
- Several new patches (mostly small changes to include statements) to allow compilation with clang
- ncurses from ports is now mandatory due to changes in ncmpcpp and the new 256 color support

This update was tested with Poudriere on FreeBSD 9.3, 10.1 and 10.2
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-12 14:28:11 UTC
@Yamagi thank you, can you please confirm this passes QA (portlint/poudriere)
Comment 2 yamagi 2015-11-12 15:33:14 UTC
It does. Poudriere build the ports without any problem on 9.3, 10.1 and 10.2. Portlint is happy, too. I can change DISTFILES to DISTNAME if necessary to suppress a portlint warning that DISTFILES is discouraged...
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-12 16:03:31 UTC
You're the (maintainer) boss :)
Comment 4 yamagi 2015-11-13 10:34:52 UTC
Okay, in that case: I've attached a new patch with DISTNAME instead of DISTFILES. Poudriere is still happy and portlint is down to one small warning ("COMMENT should begin with a capital, and end without a period"). I'll leave that warning in because "Ncmpcpp" look weird. You can go ahead and commit the patch. Thank you. :)
Comment 5 yamagi 2015-11-13 10:35:37 UTC
Created attachment 163088 [details]
Update to 0.7.0b1 (with DISTNAME instead fo DISTFILES)
Comment 6 commit-hook freebsd_committer 2015-11-15 16:21:05 UTC
A commit references this bug:

Author: riggs
Date: Sun Nov 15 16:21:02 UTC 2015
New revision: 401713
URL: https://svnweb.freebsd.org/changeset/ports/401713

Log:
  Update to upstream version 0.7.0-b1

  PR:		204499
  Submitted by:	yamagi@yamagi.org (maintainer)

Changes:
  head/audio/ncmpcpp/Makefile
  head/audio/ncmpcpp/distinfo
  head/audio/ncmpcpp/files/patch-src__status.cpp
  head/audio/ncmpcpp/files/patch-src_bindings.cpp
  head/audio/ncmpcpp/files/patch-src_browser.cpp
  head/audio/ncmpcpp/files/patch-src_configuration.cpp
  head/audio/ncmpcpp/files/patch-src_helpers.cpp
  head/audio/ncmpcpp/files/patch-src_media__library.cpp
  head/audio/ncmpcpp/files/patch-src_mpdpp.cpp
  head/audio/ncmpcpp/files/patch-src_mpdpp.h
  head/audio/ncmpcpp/files/patch-src_playlist.cpp
  head/audio/ncmpcpp/files/patch-src_playlist__editor.cpp
  head/audio/ncmpcpp/files/patch-src_search__engine.cpp
  head/audio/ncmpcpp/files/patch-src_status.cpp
  head/audio/ncmpcpp/files/patch-src_tag__editor.cpp
  head/audio/ncmpcpp/files/patch-src_window.h
  head/audio/ncmpcpp/pkg-message