Bug 204567 - devel/py-asn1: Update to 0.1.9 and rename to devel/py-pyasn1
Summary: devel/py-asn1: Update to 0.1.9 and rename to devel/py-pyasn1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ruslan Makhmatkhanov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-15 18:29 UTC by John W. O'Brien
Modified: 2016-01-12 00:01 UTC (History)
4 users (show)

See Also:
mhjacks: maintainer-feedback+


Attachments
devel/py-asn1: Update to 0.1.9, rename, bump dependent ports (16.03 KB, patch)
2015-11-15 18:29 UTC, John W. O'Brien
john: maintainer-approval? (mhjacks)
Details | Diff
py27-pyasn1-0.1.9 testport log (25.66 KB, text/plain)
2015-11-15 18:30 UTC, John W. O'Brien
no flags Details
py34-pyasn1-0.1.9 testport log (25.89 KB, text/plain)
2015-11-15 18:30 UTC, John W. O'Brien
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description John W. O'Brien 2015-11-15 18:29:38 UTC
Created attachment 163153 [details]
devel/py-asn1: Update to 0.1.9, rename, bump dependent ports

Changelog:

*   Update to 0.1.9
*   Move to devel/py-pyasn1 to match PyPI name
*   Update *_DEPENDS and bump PORTREVISION in dependent ports
*   Reset PORTEPOCH

QA:

*   portlint: OK (0 fatal, 1 warning)
*   testport: OK (10.1-RELEASE-p22, amd64, python27 and python34)
Comment 1 John W. O'Brien 2015-11-15 18:30:38 UTC
Created attachment 163154 [details]
py27-pyasn1-0.1.9 testport log
Comment 2 John W. O'Brien 2015-11-15 18:30:54 UTC
Created attachment 163155 [details]
py34-pyasn1-0.1.9 testport log
Comment 3 mhjacks 2015-11-15 22:51:57 UTC
Thanks for the work to improve pyasn1!  I've not done a maintainer approval in bugzilla, but my intention is absolutely to approve this.
Comment 4 John W. O'Brien 2015-11-15 23:42:28 UTC
You're welcome. I'm glad to help.

Incidentally, per bug #201907, comment #3, here I am saying that I ran Tools/scripts/MOVEDlint.awk and it didn't complain.
Comment 5 commit-hook freebsd_committer 2015-11-18 21:42:00 UTC
A commit references this bug:

Author: rm
Date: Wed Nov 18 21:41:50 UTC 2015
New revision: 401898
URL: https://svnweb.freebsd.org/changeset/ports/401898

Log:
  devel/py-asn1: move to devel/py-pyasn1 to match PyPI name

  - move to devel/py-pyasn1 to match PyPI name
  - update *_DEPENDS and bump PORTREVISION in dependent ports
  - reset PORTEPOCH

  PR:		204567
  Submitted by:	John W. O'Brien <john@saltant.com>
  Approved by:	mhjacks@swbell.net (maintainer of devel/py-asn1)

Changes:
  head/MOVED
  head/devel/Makefile
  head/devel/py-asn1/
  head/devel/py-pyasn1/
  head/devel/py-pyasn1/Makefile
  head/net/py-impacket/Makefile
  head/net/py-ldap3/Makefile
  head/net/py-ndg_httpsclient/Makefile
  head/net/py-netlib/Makefile
  head/net/py-pysmb/Makefile
  head/net-im/gajim/Makefile
  head/net-mgmt/py-snmp4/Makefile
  head/net-p2p/tribler/Makefile
  head/security/py-acme/Makefile
  head/security/py-cryptography/Makefile
  head/security/py-oauth2client/Makefile
  head/security/py-rsa/Makefile
  head/security/py-service_identity/Makefile
  head/security/py-twistedConch/Makefile
  head/sysutils/azure-agent/Makefile
  head/www/mitmproxy/Makefile
Comment 6 commit-hook freebsd_committer 2015-11-18 21:49:02 UTC
A commit references this bug:

Author: rm
Date: Wed Nov 18 21:48:05 UTC 2015
New revision: 401899
URL: https://svnweb.freebsd.org/changeset/ports/401899

Log:
  devel/py-pyasn1: update to 0.1.9

  PR:		204567
  Submitted by:	John W. O'Brien <john@saltant.com>
  Approved by:	mhjacks@swbell.net (maintainer)

Changes:
  head/devel/py-pyasn1/Makefile
  head/devel/py-pyasn1/distinfo
Comment 7 Ruslan Makhmatkhanov freebsd_committer 2015-11-18 21:50:30 UTC
Committed, thank you! As always great submission, John!
Comment 8 graham 2016-01-03 22:34:39 UTC
This change has broken portupgrade for me. When I try to run it, I get:

===>  Installing for py27-pyasn1-0.1.9
===>   py27-pyasn1-0.1.9 depends on package: py27-setuptools27>0 - found
===>   py27-pyasn1-0.1.9 depends on file: /usr/local/bin/python2.7 - found
===>  Checking if py27-pyasn1 already installed
===>   Registering installation for py27-pyasn1-0.1.9 as automatic
Installing py27-pyasn1-0.1.9...
pkg-static: py27-pyasn1-0.1.9 conflicts with py27-asn1-0.1.8,1 (installs files into the same place).  Problematic file: /usr/local/lib/python2.7/site-packages/pyasn1/__init__.py
*** Error code 70

Stop.


Any hints please? Should there be an entry in UPDATING?
Comment 9 graham 2016-01-04 02:33:44 UTC
(In reply to graham from comment #8)

I should also say that I know I can "pkg delete py27-asn1-0.1.8,1" and all its dependencies and then rebuild them all. But I don't think that should be necessary.

Graham
Comment 10 John W. O'Brien 2016-01-07 02:52:32 UTC
(In reply to graham from comment #8)

I'm sorry for the delay. I tried to post a response a day or two ago, but it appears to have been lost.

It has been many moons since I last used portupgrade, so my chops are rusty to say the least. However, this patch registers the new name in MOVED, so I believe that it meets its requirements w.r.t. the ports infrastructure. portupgrade has been MOVED-aware since v2.4.9.8 according to the latest release notes (https://github.com/freebsd/portupgrade/blob/2.4.14/NEWS.md).

My main hint is to investigate the "-o" option for portupgrade. If neither of these leads proves fruitful, please provide more detail about the state of your system (versions of FreeBSD and portupgrade, at least, and the update method and relative snapshots of the ports tree) and the things you have tried (detailed command lines and full output as an attachment), to help us determine if this is a port-specific regression or a portupgrade support issue.
Comment 11 Kubilay Kocak freebsd_committer freebsd_triage 2016-01-07 03:32:25 UTC
@Graham/John, please note this issue is closed. A new issue should be created (if still desired) referencing this issue in the new See Also field. It may even be an issue report against Summary: "ports-mgmt/portupgrade:" so that the maintainer is actually notified
Comment 12 graham 2016-01-12 00:01:52 UTC
(In reply to John W. O'Brien from comment #10)

Thanks for replying, John.

I've tried using "-o" but it didn't work. And MOVED doesn't seem to have the done job either. It's probably my fault - but I don't know.

In the end, I deleted the old package and all its dependencies, installed the old package, and reinstalled all the dependencies. Not ideal, but it seems to have worked.