Bug 204650 - [libc][rpc-svc][patch] rendezvous_request() does not populate local address
Summary: [libc][rpc-svc][patch] rendezvous_request() does not populate local address
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2015-11-18 01:17 UTC by alex.burlyga.ietf
Modified: 2016-07-24 22:25 UTC (History)
0 users

See Also:


Attachments
Populate local address when creating new transporter for connection oritented transporters (1.43 KB, patch)
2015-11-18 01:24 UTC, alex.burlyga.ietf
no flags Details | Diff
Populate local address when creating new transporter for connection oritented transporters (1.19 KB, patch)
2015-11-19 03:48 UTC, alex.burlyga.ietf
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description alex.burlyga.ietf 2015-11-18 01:17:20 UTC
For connection oriented transporters when creating rendezvous transporter rpc library does not populate on which local address this transporter was created.

patch which fixes the problem is coming up.
Comment 1 alex.burlyga.ietf 2015-11-18 01:24:19 UTC
Created attachment 163272 [details]
Populate local address when creating new transporter for connection oritented transporters
Comment 2 alex.burlyga.ietf 2015-11-19 03:48:56 UTC
Created attachment 163319 [details]
Populate local address when creating new transporter for connection oritented transporters
Comment 3 alex.burlyga.ietf 2015-11-19 03:51:40 UTC
Also if people want to look at the phabricator here is the link:
https://reviews.freebsd.org/D4206
Comment 4 Pedro F. Giffuni freebsd_committer 2016-07-24 22:25:01 UTC
Committed as r292047 (from Code Review)