Bug 204656 - dns/p5-Net-DNS: 1.0.3 changed API in point release, Breaks several ports.
Summary: dns/p5-Net-DNS: 1.0.3 changed API in point release, Breaks several ports.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-perl (Nobody)
URL: https://rt.cpan.org/Public/Bug/Displa...
Keywords: needs-patch, needs-qa, regression
Depends on:
Blocks:
 
Reported: 2015-11-18 09:36 UTC by lampa
Modified: 2015-11-23 09:24 UTC (History)
3 users (show)

See Also:
koobs: maintainer-feedback? (perl)
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lampa 2015-11-18 09:36:57 UTC
See https://rt.cpan.org/Public/Bug/Display.html?id=108745, please take it out!
It breaks also mimedefang.
Comment 1 commit-hook freebsd_committer 2015-11-20 15:26:15 UTC
A commit references this bug:

Author: jadawin
Date: Fri Nov 20 15:25:30 UTC 2015
New revision: 402091
URL: https://svnweb.freebsd.org/changeset/ports/402091

Log:
  Revert because upstream is really buggy with many impacts: https://rt.cpan.org/Public/Bug/Display.html?id=108745

  PR:		204656
  Submitted by:	lampa@fit.vutbr.cz

Changes:
  head/dns/p5-Net-DNS/Makefile
  head/dns/p5-Net-DNS/distinfo
Comment 2 Philippe Audeoud freebsd_committer 2015-11-23 09:24:01 UTC
Revert done. Thanks.