Bug 204754 - audio/festival: Update to 2.4
Summary: audio/festival: Update to 2.4
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords: patch, patch-ready
Depends on:
Blocks:
 
Reported: 2015-11-22 18:39 UTC by Michael Danilov
Modified: 2015-11-29 20:12 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (mi)


Attachments
audio/festival (13.36 KB, patch)
2015-11-22 18:39 UTC, Michael Danilov
no flags Details | Diff
audio/festival: portlint -AC (3.46 KB, text/plain)
2015-11-22 18:42 UTC, Michael Danilov
koobs: maintainer-approval? (mi)
Details
audio/festival: poudriere output (143.22 KB, text/plain)
2015-11-22 18:44 UTC, Michael Danilov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Danilov 2015-11-22 18:39:47 UTC
Created attachment 163438 [details]
audio/festival

In some patches there are chunks left that still differ from new code -- need someone with knowledge to look at them:

files/patch-debian-bug-667377

Original version of these were downloaded as distfiles:
files/patch-speech__tools_config_compilers_gcc__defaults.mak
files/patch-speech__tools_include_EST__Ngrammar.h
files/patch-speech__tools_include_EST__String.h

In files/patch-voxware "char *audiodevice;" has already been replaced with "const char *audiodevice;" where the old patch did. But there is one more location where "char *audiodevice;" is untouched -- I made the patch replace there instead.

files/patch-festival_src_modules_hts_engine_HTS_misc.c is a dirty hack: there is no proper detection of FreeBSD in the file.
Comment 1 Michael Danilov 2015-11-22 18:42:59 UTC
Created attachment 163439 [details]
audio/festival: portlint -AC
Comment 2 Michael Danilov 2015-11-22 18:44:32 UTC
Created attachment 163440 [details]
audio/festival: poudriere output
Comment 3 Kurt Jaeger freebsd_committer 2015-11-29 19:22:19 UTC
Test-builds on 11a, 10.2a+i, 9.3a are fine.
Comment 4 Michael Danilov 2015-11-29 19:31:05 UTC
Please try building without those (in groups):

1. files/patch-debian-bug-667377        <-- also without last 2 chunks

2. files/patch-speech__tools_include_EST__Ngrammar.h files/patch-speech__tools_include_EST__String.h

3. files/patch-speech__tools_config_compilers_gcc__defaults.mak

I can do it myself, but not sooner than tomorrow's evening.
Comment 5 Mikhail Teterin freebsd_committer 2015-11-29 19:41:58 UTC
If the test (a.k.a. post-build) target succeeds everywhere, please, go ahead and commit the upgrade. Thank you!
Comment 6 Michael Danilov 2015-11-29 19:46:33 UTC
The problem is those patches may be unnecessary and cause problems in the future.
Comment 7 Kurt Jaeger freebsd_committer 2015-11-29 19:48:49 UTC
I'm testbuilding without the four patch-files as requested. If it succeeds,
I'll commit this.
Comment 8 Kurt Jaeger freebsd_committer 2015-11-29 20:03:09 UTC
Test-builds on 11a, 10.2a+i, 9.3a with the four patches removed are fine, too.
Comment 9 commit-hook freebsd_committer 2015-11-29 20:10:44 UTC
A commit references this bug:

Author: pi
Date: Sun Nov 29 20:09:50 UTC 2015
New revision: 402619
URL: https://svnweb.freebsd.org/changeset/ports/402619

Log:
  audio/festival: 2.1 -> 2.4

  - Updated HTS and CG engines
  - Support for newer compilers
  - Bug fixes galore.

  PR:		204754
  Submitted by:	Michael Danilov <mike.d.ft402@gmail.com>
  Approved by:	mi (maintainer)

Changes:
  head/audio/festival/Makefile
  head/audio/festival/distinfo
  head/audio/festival/files/patch-debian-bug-667377
  head/audio/festival/files/patch-festival_src_modules_hts_engine_HTS_misc.c
  head/audio/festival/files/patch-voxware
  head/audio/festival/pkg-plist
Comment 10 Kurt Jaeger freebsd_committer 2015-11-29 20:12:00 UTC
Committed, thanks.