Bug 204762 - [patch] emulators/pipelight: update to 0.2.8.2
Summary: [patch] emulators/pipelight: update to 0.2.8.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitry Marakasov
URL:
Keywords: easy, needs-qa, patch
Depends on:
Blocks:
 
Reported: 2015-11-23 09:42 UTC by Piotr Kubaj
Modified: 2015-12-04 15:49 UTC (History)
0 users

See Also:


Attachments
pipelight 0.2.8.2 (2.81 KB, patch)
2015-11-23 09:42 UTC, Piotr Kubaj
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2015-11-23 09:42:03 UTC
Created attachment 163451 [details]
pipelight 0.2.8.2

Recently the new version of emulation/pipelight was released. The patch for it is attached. It builds fine on 10.2-RELEASE.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-27 02:22:48 UTC
Comment on attachment 163451 [details]
pipelight 0.2.8.2

Port is un-maintained, implicit approval
Comment 2 Dmitry Marakasov freebsd_committer 2015-12-02 19:08:17 UTC
Please resubmit patch with correct line endings.

> unified diff output, ASCII text, with CRLF line terminators
                                        ^^^^
Comment 3 Piotr Kubaj freebsd_committer 2015-12-03 16:41:30 UTC
(In reply to Dmitry Marakasov from comment #2)
I'm not sure why you see CRLF line endings, I don't have those and I certainly didn't create this patch on Windows, as I don't use Windows. It was created and sent from FreeBSD.
Comment 4 commit-hook freebsd_committer 2015-12-04 15:47:48 UTC
A commit references this bug:

Author: amdmi3
Date: Fri Dec  4 15:46:59 UTC 2015
New revision: 402998
URL: https://svnweb.freebsd.org/changeset/ports/402998

Log:
  - Update to 0.2.8.2

  PR:		204762
  Submitted by:	pkubaj@riseup.net

Changes:
  head/emulators/pipelight/Makefile
  head/emulators/pipelight/distinfo
  head/emulators/pipelight/files/patch-Makefile
Comment 5 Dmitry Marakasov freebsd_committer 2015-12-04 15:49:06 UTC
% wget 'https://bugs.freebsd.org/bugzilla/attachment.cgi?id=163451' -qO- | file -
/dev/stdin: unified diff output, ASCII text, with CRLF line terminators

You should try file on the patch produced by your svn to check if the problem is there (maybe some weird line ending settings?). Otherwise it may be browser or bugzilla problem.

Committed the fixed patch.