Bug 204773 - net/opensips: Update to 2.1.1 + port improvements.
Summary: net/opensips: Update to 2.1.1 + port improvements.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords: needs-patch, patch, patch-ready
: 204660 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-11-24 05:23 UTC by Euan Thoms
Modified: 2015-11-25 19:29 UTC (History)
2 users (show)

See Also:


Attachments
Diff patch between current port version and upgrade to v2.1.1 (15.37 KB, patch)
2015-11-24 05:23 UTC, Euan Thoms
euan: maintainer-approval+
Details | Diff
Poudriere testport log on 10.1 RELEASE amd64 (266.57 KB, text/x-log)
2015-11-24 06:30 UTC, Euan Thoms
no flags Details
Diff patch between current port version and upgrade to v2.1.1 (16.41 KB, patch)
2015-11-25 05:58 UTC, Euan Thoms
euan: maintainer-approval-
Details | Diff
Diff patch between current port version and upgrade to v2.1.1 (16.41 KB, patch)
2015-11-25 07:14 UTC, Euan Thoms
euan: maintainer-approval-
Details | Diff
Diff patch between current port version and upgrade to v2.1.1 (15.81 KB, patch)
2015-11-25 09:04 UTC, Euan Thoms
euan: maintainer-approval+
Details | Diff
Poudriere testport log on 10.1 RELEASE amd64 (266.28 KB, text/x-log)
2015-11-25 09:05 UTC, Euan Thoms
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Euan Thoms 2015-11-24 05:23:42 UTC
Created attachment 163462 [details]
Diff patch between current port version and upgrade to v2.1.1

Update to version 2.1.1.

Also fixed TLS support by including proto_tls module.

Added cachedb_redis module to core of port (since no extra deps are required).

Some tidying up and improvements in Makefile and pkg-plist.
Comment 1 Euan Thoms 2015-11-24 05:40:57 UTC
Portlint passes:

[root@portdev /usr/ports/net/opensips]# portlint -AC
WARN: Makefile: for new port, make $FreeBSD$ tag in comment section empty, to make SVN happy.
0 fatal errors and 1 warning found.
Comment 2 Euan Thoms 2015-11-24 06:30:27 UTC
Created attachment 163464 [details]
Poudriere testport log on 10.1 RELEASE amd64

Poudriere testport passes on 10.1 amd64.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-24 07:01:04 UTC
Euan,

You should be able to use <OPTION>_VARS_ON=EXTRA_MODULES+=proto_tls instead of the .if ${PORT_OPTIONS:MTLS} block.

Don't forget to set maintainer-approval to + on attachments for ports you are maintainer of
Comment 4 Euan Thoms 2015-11-24 07:53:03 UTC
(In reply to Kubilay Kocak from comment #3)

Aha! Maybe that's why my ports are not getting committed fast enough. I didn't notice the maintainer approval thingy.
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-24 08:01:11 UTC
*** Bug 204660 has been marked as a duplicate of this bug. ***
Comment 6 Euan Thoms 2015-11-25 05:58:29 UTC
Created attachment 163494 [details]
Diff patch between current port version and upgrade to v2.1.1

Improved options helpers (to new standards) in Makefile.
Comment 7 Euan Thoms 2015-11-25 07:00:39 UTC
Comment on attachment 163494 [details]
Diff patch between current port version and upgrade to v2.1.1

options helpers breaks build
Comment 8 Euan Thoms 2015-11-25 07:14:08 UTC
Created attachment 163497 [details]
Diff patch between current port version and upgrade to v2.1.1

Fixed tab indentation on options helpers.
Comment 9 Euan Thoms 2015-11-25 07:34:51 UTC
Comment on attachment 163497 [details]
Diff patch between current port version and upgrade to v2.1.1

More breakage by options helpers changes.
Comment 10 Euan Thoms 2015-11-25 08:48:01 UTC
I've given up trying to convert the EXTRA_MODULES+= section to the new options helpers syntax.

The following:
>>>>>>>>>>>>>
pre-configure-MYSQL-on:
        EXTRA_MODULES+=db_mysql
<<<<<<<<<<<<<

results in:

===>  Configuring for opensips-2.1.1
EXTRA_MODULES+=db_mysql
EXTRA_MODULES+=db_mysql: not found
*** Error code 127
Comment 11 Euan Thoms 2015-11-25 09:04:37 UTC
Created attachment 163510 [details]
Diff patch between current port version and upgrade to v2.1.1

Reverted options helpers for setting EXTRA_MODULES. Tested with poudriere. Ready to commit now.
Comment 12 Euan Thoms 2015-11-25 09:05:58 UTC
Created attachment 163511 [details]
Poudriere testport log on 10.1 RELEASE amd64

Updated poudriere testport log for 10.1 RELEASE amd64.
Comment 13 Kurt Jaeger freebsd_committer 2015-11-25 09:37:08 UTC
Testing@work
Comment 14 commit-hook freebsd_committer 2015-11-25 19:28:12 UTC
A commit references this bug:

Author: pi
Date: Wed Nov 25 19:28:01 UTC 2015
New revision: 402407
URL: https://svnweb.freebsd.org/changeset/ports/402407

Log:
  net/opensips: 2.1.0 -> 2.1.1

  Changes:
    http://opensips.org/pub/opensips/2.1.1/ChangeLog

  PR:		204773
  Submitted by:	Euan Thoms <euan@potensol.com> (maintainer)

Changes:
  head/net/opensips/Makefile
  head/net/opensips/distinfo
  head/net/opensips/files/Makefile.conf
  head/net/opensips/files/patch-Makefile
  head/net/opensips/files/patch-Makefile.defs
  head/net/opensips/files/patch-io_wait.h
  head/net/opensips/files/patch-mem__shm_mem.h
  head/net/opensips/files/patch-modules__proto_tls__proto_tls.c
  head/net/opensips/files/patch-net__net_tcp.c
  head/net/opensips/files/patch-net__net_tcp_proc.c
  head/net/opensips/pkg-plist
Comment 15 Kurt Jaeger freebsd_committer 2015-11-25 19:29:04 UTC
Committed, thanks!