Bug 204958 - [NEW] multimedia/libyuv: YYUV scaling and conversion functionality (Needed for FreeSWITCH)
Summary: [NEW] multimedia/libyuv: YYUV scaling and conversion functionality (Needed fo...
Status: Closed DUPLICATE of bug 205680
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: feature, needs-qa, patch
Depends on:
Blocks: 204967
  Show dependency treegraph
 
Reported: 2015-12-02 09:22 UTC by Šimun Mikecin
Modified: 2016-03-07 08:52 UTC (History)
3 users (show)

See Also:


Attachments
libyuv-1514 (2.57 KB, text/plain)
2015-12-02 09:22 UTC, Šimun Mikecin
no flags Details
libyuv port (5.41 KB, text/plain)
2015-12-02 10:13 UTC, Šimun Mikecin
no flags Details
libyuv port. (5.40 KB, text/plain)
2015-12-02 10:38 UTC, Šimun Mikecin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Šimun Mikecin 2015-12-02 09:22:05 UTC
Created attachment 163739 [details]
libyuv-1514

libyuv is an open source project that includes YUV scaling and conversion
functionality.

Scale YUV to prepare content for compression, with point, bilinear or box
filter.
Convert to YUV from webcam formats.
Convert from YUV to formats for rendering/effects.
Rotate by 90/180/270 degrees to adjust for mobile devices in portrait mode.

Optimized for SSE2/SSSE3/AVX2 on x86/x64.
Optimized for Neon on Arm.
Optimized for DSP R2 on Mips.

WWW: https://code.google.com/p/libyuv/

This port is needed for porting FreeSWITCH:
WWW: http://www.freeswitch.org
Comment 1 Šimun Mikecin 2015-12-02 10:13:11 UTC
Created attachment 163742 [details]
libyuv port
Comment 2 Šimun Mikecin 2015-12-02 10:38:48 UTC
Created attachment 163743 [details]
libyuv port.

-fPIC is needed for linking with FreeSWITCH.
libyuv-config is needed for building FreeSWITCH.
Comment 3 Kurt Jaeger freebsd_committer 2016-03-06 20:49:58 UTC

*** This bug has been marked as a duplicate of bug 205680 ***
Comment 4 commit-hook freebsd_committer 2016-03-07 08:49:56 UTC
A commit references this bug:

Author: pi
Date: Mon Mar  7 08:49:03 UTC 2016
New revision: 410509
URL: https://svnweb.freebsd.org/changeset/ports/410509

Log:
  New port: graphics/libyuv

  libyuv is an open source project that includes YUV scaling and conversion
  functionality.

  - Prepare content for compression, with point, bilinear or box filter.
  - Convert to YUV from webcam formats.
  - Convert from YUV to formats for rendering/effects.
  - Rotate by 90/180/270 degrees to adjust for mobile devices in portrait mode.
  - Optimized versions for SSE2/SSSE3/AVX2 on x86/x64,
    Neon on Arm, DSP R2 Mips are possible.

  WWW: https://chromium.googlesource.com/libyuv/libyuv/

  PR:		205680, 204958
  Submitted by:	Corey Smith <corsmith@gmail.com>, numisemis@yahoo.com

Changes:
  head/graphics/Makefile
  head/graphics/libyuv/
  head/graphics/libyuv/Makefile
  head/graphics/libyuv/distinfo
  head/graphics/libyuv/files/
  head/graphics/libyuv/files/patch-Makefile
  head/graphics/libyuv/pkg-descr
  head/graphics/libyuv/pkg-plist