Bug 205058 - Page fault in amd64_syscall() -> sys_kevent() -> kern_kevent() at sys/kern/kern_event.c:1520 on 10.2-STABLE r291236
Summary: Page fault in amd64_syscall() -> sys_kevent() -> kern_kevent() at sys/kern/ke...
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.2-STABLE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords: panic
Depends on:
Blocks:
 
Reported: 2015-12-06 13:30 UTC by Ludger Bolmerg
Modified: 2019-02-22 07:43 UTC (History)
1 user (show)

See Also:


Attachments
core.txt.0 (390.05 KB, text/plain)
2015-12-06 13:30 UTC, Ludger Bolmerg
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ludger Bolmerg 2015-12-06 13:30:15 UTC
Created attachment 163896 [details]
core.txt.0

Fatal trap 12: page fault while in kernel mode
cpuid = 2; apic id = 04
fault virtual address   = 0x18
fault code              = supervisor read data, page not present
instruction pointer     = 0x20:0xffffffff80904e29
stack pointer           = 0x28:0xfffffe0114b71830
frame pointer           = 0x28:0xfffffe0114b71a20
code segment            = base rx0, limit 0xfffff, type 0x1b
                        = DPL 0, pres 1, long 1, def32 0, gran 1
processor eflags        = interrupt enabled, resume, IOPL = 0
current process         = 1791 (kdeinit4)
trap number             = 12
panic: page fault
cpuid = 2
KDB: stack backtrace:
#0 0xffffffff80983060 at kdb_backtrace+0x60
#1 0xffffffff80946b46 at vpanic+0x126
#2 0xffffffff80946a13 at panic+0x43
#3 0xffffffff80d498db at trap_fatal+0x36b
#4 0xffffffff80d49bdd at trap_pfault+0x2ed
#5 0xffffffff80d4927a at trap+0x47a
#6 0xffffffff80d2f282 at calltrap+0x8
#7 0xffffffff8090479a at sys_kevent+0x12a
#8 0xffffffff80d4a2af at amd64_syscall+0x40f
#9 0xffffffff80d2f56b at Xfast_syscall+0xfb
Comment 1 Andriy Voskoboinyk freebsd_committer 2019-02-21 23:06:27 UTC
I suspect the issue is just the same as in bug #234561 (already fixed in base r340734); can you reproduce the panic with recent base / kernel?
Comment 2 Ludger Bolmerg 2019-02-22 07:40:55 UTC
(In reply to Andriy Voskoboinyk from comment #1)
I am on 12.0-RELEASE-p3 now. Everything is working ok. I can't reproduce the bug.
Thank you
Comment 3 Andriy Voskoboinyk freebsd_committer 2019-02-22 07:43:27 UTC
(In reply to Ludger Bolmerg from comment #2)
Great, thanks for fast reply.