Bug 205071 - audio/ncmpcpp: Update to 0.7 and fix build
Summary: audio/ncmpcpp: Update to 0.7 and fix build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Martin Wilke
URL:
Keywords: needs-qa, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2015-12-06 18:22 UTC by yamagi
Modified: 2016-01-10 07:35 UTC (History)
3 users (show)

See Also:
koobs: maintainer-feedback? (yamagi)


Attachments
svn patch to version 0.7 (1.22 KB, patch)
2015-12-06 18:22 UTC, yamagi
no flags Details | Diff
svn patch to version 0.7.0 (second version) (1.14 KB, patch)
2015-12-09 13:53 UTC, yamagi
yamagi: maintainer-approval+
Details | Diff
ncmpcpp 0.7.1 (1.12 KB, patch)
2016-01-04 13:53 UTC, yamagi
yamagi: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description yamagi 2015-12-06 18:22:59 UTC
Created attachment 163911 [details]
svn patch to version 0.7

The attached patch updates audio/ncmpcpp to version 0.7 final. This is just a small bugfix update over beta 1:

 * Playlist sorting dialog now contains ‘Album artist’ option.
 * Default keybindings were corrected to allow tag edition in the right column of tag editor.
 * Mouse is properly kept disabled if it was disabled in the configuration file.

In the port I've changed the ncurses dependency back to 'base' for 3 reasons:

 1) This was requested several times by users.
 2) Other than I thought there's no need in using the ports ncurses.
 3) The update of devel/ncurses to 6.0 broke ncmpcpps configure script and until now I wasn't able to find a clean work around.
Comment 1 yamagi 2015-12-06 20:31:30 UTC
I forgot to mention that I've tested the port with Poudriere on 10.2, 10.1 and 9.3.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2015-12-07 05:18:47 UTC
I think this is going to cause PORTVERSION to go backwards, requiring a PORTEPOCH bump.

# pkg version -t 0.7.0b1 0.7
>

The root cause appears to be prior/current use of PORTVERSION (instead of DISTVERSION) for alpha/beta/non-integer versions.

Also, regarding ncurses issue (3), I believe all issues have now rectified by bapt@. If not, please report a new issue under "devel/ncurses:"

Please also set maintainer-approval to + on attachments you create on ports/issues you are maintainer of, instead of the [MAINTAINER] summary tag.

Thanks!
Comment 3 yamagi 2015-12-09 13:51:29 UTC
Okay, using 0.7.0b1 for the beta was stupid. Very stupid. I'll remember that for the next alpha or beta version. Having read the porters handbook chapter about 	PORTEPOCH I've decided not to go that way and bump the version to 0.7.0f (f for final). When 0.7.1 is released I can switch back to the upstream version number scheme.

% pkg version -t 0.7.0b1 0.7.0f
<

% pkg version -t 0.7.0f 0.7.1
<

Since bug #205155 provided a clean, non hacky solution for the ncurses problem and working 256 color support is more valuable than the complaints of 2 users I've changed the ncurses dependency back to ports.

This second version of the patch was tested with Poudriere on 10.2, 10.1 and 9.3.
Comment 4 yamagi 2015-12-09 13:53:02 UTC
Created attachment 164015 [details]
svn patch to version 0.7.0 (second version)
Comment 5 yamagi 2016-01-04 13:53:20 UTC
Created attachment 165054 [details]
ncmpcpp 0.7.1
Comment 6 yamagi 2016-01-04 13:54:29 UTC
Another version. This time an update to 0.7.1 (version bump only, no changes to the port) without any version number chaos. As always this patch was tested with Poudriere on FreeBSD 10.2, 10.2 and 9.3.
Comment 7 commit-hook freebsd_committer 2016-01-10 07:35:15 UTC
A commit references this bug:

Author: miwi
Date: Sun Jan 10 07:35:03 UTC 2016
New revision: 405678
URL: https://svnweb.freebsd.org/changeset/ports/405678

Log:
  - Update to 0.7.1

  PR:		205071
  Submitted by:	maintainer

Changes:
  head/audio/ncmpcpp/Makefile
  head/audio/ncmpcpp/distinfo