Bug 205125 - graphics/png: Fails to build on sparc64
Summary: graphics/png: Fails to build on sparc64
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Port Management Team
URL:
Keywords: needs-qa, regression
Depends on:
Blocks:
 
Reported: 2015-12-08 08:48 UTC by Henry Jalonen
Modified: 2015-12-18 02:36 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (portmgr)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henry Jalonen 2015-12-08 08:48:46 UTC
Building png 1.6.20 fails on sparc64 (FreeBSD 9.3-RELEASE-p24) in tests/pngvalid-transform. The error seems identical with the failing MIPS build log at pkg-fallout message http://lists.freebsd.org/pipermail/freebsd-pkg-fallout/Week-of-Mon-20151207/274162.html
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2015-12-08 08:52:34 UTC
@Henkka, is this a regression on the previous version?
Comment 2 Henry Jalonen 2015-12-08 09:03:10 UTC
I have 1.6.19 installed, which compiled fine on Mon Nov 16 16:03:28 2015 EET. The system has not been updated since then.
Comment 3 commit-hook freebsd_committer 2015-12-08 18:23:38 UTC
A commit references this bug:

Author: antoine
Date: Tue Dec  8 18:23:29 UTC 2015
New revision: 403332
URL: https://svnweb.freebsd.org/changeset/ports/403332

Log:
  Do not fail the build if regression tests do not pass, there seems to
  be a regression on big endian archs between versions 1.6.19 and 1.6.20
  (reported upstream)

  PR:		205125
  MFH:		2015Q4

Changes:
  head/graphics/png/Makefile
Comment 4 commit-hook freebsd_committer 2015-12-08 19:34:44 UTC
A commit references this bug:

Author: antoine
Date: Tue Dec  8 19:33:57 UTC 2015
New revision: 403344
URL: https://svnweb.freebsd.org/changeset/ports/403344

Log:
  MFH: r403332

  Do not fail the build if regression tests do not pass, there seems to
  be a regression on big endian archs between versions 1.6.19 and 1.6.20
  (reported upstream)

  PR:		205125

Changes:
_U  branches/2015Q4/
  branches/2015Q4/graphics/png/Makefile
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2015-12-18 02:36:24 UTC
Workaround committed for now so that port will build.  Upstream needs to be notified about the problem of not building on various arches.