Bug 205133 - devel/apr1: Fails poudriere build: Missing: libdata/pkgconfig/apr-util-1.pc
Summary: devel/apr1: Fails poudriere build: Missing: libdata/pkgconfig/apr-util-1.pc
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-apache (Nobody)
URL:
Keywords: easy, needs-patch, needs-qa, regression
Depends on:
Blocks:
 
Reported: 2015-12-08 14:29 UTC by Yuri Victorovich
Modified: 2015-12-09 09:16 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (apache)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2015-12-08 14:29:48 UTC
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: lib/pkgconfig/apr-util-1.pc
===> Checking for items in pkg-plist which are not in STAGEDIR
Error: Missing: libdata/pkgconfig/apr-util-1.pc
===> Error: Plist issues found.

apr-1.5.2.1.5.4
Comment 1 Olli Hauer freebsd_committer 2015-12-08 18:37:56 UTC
Hi Yuri,

I wonder what is different on your system, since I'm not able to confirm this issue.
That's what I get on two different systems, can you please check your poudriere and make sure you have the latest poudriere installed.
Do you use ports-mgmt/poudriere-devel or ports-mgmt/poudriere?
With poudriere-devel-3.1.99.20151125 I got once an error in a different port since poudriere was cleaning the jail before the build was finished, but this is fixed in the latest version)

$ svn info /usr/ports/devel/apr1
Working Copy Root Path: /usr/ports
Relative URL: ^/head/devel/apr1
Revision: 403324
...
Last Changed Author: mat
Last Changed Rev: 400848
Last Changed Date: 2015-11-05 13:36:25 +0100 (Thu, 05 Nov 2015)

$ cd /usr/ports/devel/apr1
$ make -V DEVELOPER
yes

$ script -q AA make
...
====> Compressing man pages (compress-man)
====> Running Q/A tests (stage-qa)
$ echo $?
0

$ grep 1.pc AA
/usr/bin/install -m 644 apr.pc /usr/ports/devel/apr1/work/stage/usr/local/libdata/pkgconfig/apr-1.pc
/usr/bin/install -m 644 apr-util.pc /usr/ports/devel/apr1/work/stage/usr/local/libdata/pkgconfig/apr-util-1.pc

$ ls -l work/stage/usr/local/libdata/pkgconfig/
total 4
-rw-r--r--  1 ohauer  wheel  305 Dec  8 19:19 apr-1.pc
-rw-r--r--  1 ohauer  wheel  382 Dec  8 19:19 apr-util-1.pc

$ grep 1.pc pkg-plist
libdata/pkgconfig/apr-1.pc
libdata/pkgconfig/apr-util-1.pc

$ make makeplist | grep 1.pc
libdata/pkgconfig/apr-1.pc
libdata/pkgconfig/apr-util-1.pc
Comment 2 Yuri Victorovich freebsd_committer 2015-12-08 18:52:40 UTC
Olli,

This error was produced by poudriere-3.1.9, not a very recent version. It produced various failures on 5 ports out of 800.

I will rerun with the latest version and will let you know.

Yuri
Comment 3 Olli Hauer freebsd_committer 2015-12-08 19:04:07 UTC
Hi Yuri,

OK!
Anyway if poudriere fails the log is available, perhaps you can find the issue directly there or attach the failed build log.

-- 
olli
Comment 4 Mathieu Arnold freebsd_committer 2015-12-09 09:13:24 UTC
This is a local issue, not a poudriere one.
Comment 5 Yuri Victorovich freebsd_committer 2015-12-09 09:16:52 UTC
I don't know why out of hundreds of packages this one failed.

Closing for now.