Bug 205243 - databases/phppgadmin: plist issue
Summary: databases/phppgadmin: plist issue
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords: needs-patch, needs-qa
Depends on:
Blocks:
 
Reported: 2015-12-11 11:06 UTC by Sunpoet Po-Chuan Hsieh
Modified: 2016-02-06 10:52 UTC (History)
0 users

See Also:
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sunpoet Po-Chuan Hsieh freebsd_committer 2015-12-11 11:06:38 UTC
% cd /usr/ports/databases/phppgadmin
% make install do-clean
===> Fetching all distfiles required by phppgadmin-5.1_1 for building
===>  Extracting for phppgadmin-5.1_1
=> SHA256 Checksum OK for phpPgAdmin-5.1.tar.bz2.
===>  Patching for phppgadmin-5.1_1
===>  Configuring for phppgadmin-5.1_1
/usr/bin/sed -i.bak -e "s|/usr/bin/pg|/usr/local/bin/pg|"  /usr/ports/works/usr/ports/databases/phppgadmin/work/phpPgAdmin-5.1/conf/config.inc.php-dist
/bin/rm -f -f /usr/ports/works/usr/ports/databases/phppgadmin/work/phpPgAdmin-5.1/conf/config.inc.php  /usr/ports/works/usr/ports/databases/phppgadmin/work/phpPgAdmin-5.1/conf/config.inc.php-dist.bak
===>  Staging for phppgadmin-5.1_1
===>   Generating temporary packing list
/bin/mkdir -p /usr/ports/works/usr/ports/databases/phppgadmin/work/stage/usr/local/www/phpPgAdmin
/bin/cp -Rp /usr/ports/works/usr/ports/databases/phppgadmin/work/phpPgAdmin-5.1/ /usr/ports/works/usr/ports/databases/phppgadmin/work/stage/usr/local/www/phpPgAdmin/
====> Compressing man pages (compress-man)
====> Running Q/A tests (stage-qa)
===>  Installing for phppgadmin-5.1_1
===>  Checking if phppgadmin already installed
===>   Registering installation for phppgadmin-5.1_1
Installing phppgadmin-5.1_1...
cp: /usr/local/www/data-dist/phpPgAdmin/conf/config.inc.php: No such file or directory
Comment 1 Dirk Meyer freebsd_committer 2015-12-14 14:06:52 UTC
/usr/local/www/data-dist/phpPgAdmin/conf/config.inc.php

is a location from old installations.
"No such file or directory" is normal and can be safely ignored.
Comment 2 commit-hook freebsd_committer 2016-01-14 05:24:01 UTC
A commit references this bug:

Author: dinoex
Date: Thu Jan 14 05:23:33 UTC 2016
New revision: 406093
URL: https://svnweb.freebsd.org/changeset/ports/406093

Log:
  - use @sample
  - drop support for PGADMOLDDIR
  PR:		205243

Changes:
  head/databases/phppgadmin/Makefile
  head/databases/phppgadmin/pkg-plist
Comment 3 Sunpoet Po-Chuan Hsieh freebsd_committer 2016-01-14 21:49:30 UTC
I don't think the problem is solved.

% svn st -v
            406127   406093 dinoex       .
            406127   406093 dinoex       Makefile
            406127   340717 mat          distinfo
            406127   340718 mat          pkg-descr
            406127   406093 dinoex       pkg-plist
% make package install
===>  Building package for phppgadmin-5.1_1
pkg-static: Unable to access file /usr/ports/works/usr/ports/databases/phppgadmin/work/stage/usr/local/www/phpPgAdmin/conf/config.inc.php: No such file or directory
===>  Installing for phppgadmin-5.1_1
===>  Checking if phppgadmin already installed
===>   Registering installation for phppgadmin-5.1_1
pkg-static: Unable to access file /usr/ports/works/usr/ports/databases/phppgadmin/work/stage/usr/local/www/phpPgAdmin/conf/config.inc.php: No such file or directory
Installing phppgadmin-5.1_1...
cp: /usr/local/www/phpPgAdmin/conf/config.inc.php: No such file or directory
pkg-static: POST-INSTALL script failed
Comment 4 commit-hook freebsd_committer 2016-02-06 10:51:25 UTC
A commit references this bug:

Author: dinoex
Date: Sat Feb  6 10:50:49 UTC 2016
New revision: 408290
URL: https://svnweb.freebsd.org/changeset/ports/408290

Log:
  - fix @sample
  PR:		205243

Changes:
  head/databases/phppgadmin/Makefile
  head/databases/phppgadmin/pkg-plist