Bug 205433 - databases/mysql57-{client,server}: Can not find mysql_config
Summary: databases/mysql57-{client,server}: Can not find mysql_config
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Martin Wilke
URL:
Keywords: patch, patch-ready
Depends on:
Blocks: 205465
  Show dependency treegraph
 
Reported: 2015-12-19 13:25 UTC by Tim McCormick
Modified: 2015-12-27 13:44 UTC (History)
2 users (show)

See Also:
mmokhi: maintainer-feedback+


Attachments
svn diff output as patch for mysql-server (3.31 KB, patch)
2015-12-19 17:50 UTC, Mahdi Mokhtari
mmokhi: maintainer-approval+
Details | Diff
svn diff output as patch for mysql-client (3.67 KB, patch)
2015-12-19 17:51 UTC, Mahdi Mokhtari
mmokhi: maintainer-approval+
Details | Diff
svn diff output as patch for mysql-server (revision=1) (3.68 KB, patch)
2015-12-23 12:18 UTC, Mahdi Mokhtari
mmokhi: maintainer-approval+
Details | Diff
svn diff output as patch for mysql-client (revision=1) (3.67 KB, patch)
2015-12-23 12:19 UTC, Mahdi Mokhtari
mmokhi: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tim McCormick 2015-12-19 13:25:32 UTC
net-mgmt/net-snmp is failing to build with the MYSQL option after upgrading to mysql57-client (from mysql55-client).

Configure fails with:

--

checking for mysql_config... /usr/local/bin/mysql_config
configure: error: Could not find mysql_config and was specifically asked to use MySQL support
===>  Script "configure" failed unexpectedly.
Please report the problem to zi@FreeBSD.org [maintainer] and attach the
"/usr/ports/net-mgmt/net-snmp/work/net-snmp-5.7.3/config.log" including the
output of the failure of your make command. Also, it might be a good idea to
provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/net-mgmt/net-snmp
*** Error code 1

Stop.
make: stopped in /usr/ports/net-mgmt/net-snmp

--

/usr/local/bin/mysql_config doesn't seem to exist so this is probably an issue with the mysql57-client port rather than net-snmp?

According to the mysql documentation mysql_config is still a part of 5.7:

http://dev.mysql.com/doc/refman/5.7/en/mysql-config.html

I have the following mysql packages installed:

mysql57-client-5.7.10          Multithreaded SQL database (server)
mysql57-server-5.7.10          Multithreaded SQL database (server)

Anything else you need to diagnose?
Comment 1 Mahdi Mokhtari freebsd_committer freebsd_triage 2015-12-19 14:07:03 UTC
Thanks for your feedback.
I'm on the problem.
Comment 2 Mahdi Mokhtari freebsd_committer freebsd_triage 2015-12-19 17:49:30 UTC
Hi.
Problem solved.
I should add according [1] "As of MySQL 5.7.9, pkg-config can be used as an alternative to mysql_config for obtaining information such as compiler flags or link libraries required to compile MySQL applications" 

patches attached to review (and commit).

Regards, Mokhi.

[1] http://dev.mysql.com/doc/refman/5.7/en/mysql-config.html
Comment 3 Mahdi Mokhtari freebsd_committer freebsd_triage 2015-12-19 17:50:41 UTC
Created attachment 164386 [details]
svn diff output as patch for mysql-server

patch that solves some problems for mysql57-server
Comment 4 Mahdi Mokhtari freebsd_committer freebsd_triage 2015-12-19 17:51:47 UTC
Created attachment 164387 [details]
svn diff output as patch for mysql-client

patch that solves some problems for mysql57-client
Comment 5 VK freebsd_triage 2015-12-19 23:38:58 UTC
mokhi,

thanks for the patches, but it looks like you forgot to bump PORTREVISIONs. Also, if this is your feedback to the original problem, please feel free to set maintainer-feedback+ on the issue, as well as maintainer-approval+ on the patches.
Comment 6 Mahdi Mokhtari freebsd_committer freebsd_triage 2015-12-23 12:18:21 UTC
Created attachment 164546 [details]
svn diff output as patch for mysql-server (revision=1)

PORTREVISION= 1
Comment 7 Mahdi Mokhtari freebsd_committer freebsd_triage 2015-12-23 12:19:32 UTC
Created attachment 164547 [details]
svn diff output as patch for mysql-client (revision=1)

PORTREVISION= 1
Comment 8 Mahdi Mokhtari freebsd_committer freebsd_triage 2015-12-26 15:40:07 UTC
portlint mysql57-server:
WARN: Makefile: possible use of absolute pathname "/var/db/mysql".
WARN: Makefile: new ports should not set PORTREVISION.

portlint mysql57-client:
WARN: Makefile: BUNDLED_SSL is listed in OPTIONS_DEFINE, but no PORT_OPTIONS:MBUNDLED_SSL appears.
WARN: Makefile: OPENSSL is listed in OPTIONS_DEFINE, but no PORT_OPTIONS:MOPENSSL appears.
WARN: Makefile: WITHOUT_SSL is listed in OPTIONS_DEFINE, but no PORT_OPTIONS:MWITHOUT_SSL appears.
Comment 9 Mahdi Mokhtari freebsd_committer freebsd_triage 2015-12-26 15:44:33 UTC
porttest: OK (poudriere: 93i386, 101i386 11i386)
Comment 10 commit-hook freebsd_committer 2015-12-27 02:15:47 UTC
A commit references this bug:

Author: miwi
Date: Sun Dec 27 02:15:06 UTC 2015
New revision: 404543
URL: https://svnweb.freebsd.org/changeset/ports/404543

Log:
  - Restore backwards compatibility
  - Bump PORTREVISION

  PR:	    205433

Changes:
  head/databases/mysql57-server/Makefile
  head/databases/mysql57-server/files/mysql-server.in
  head/databases/mysql57-server/files/patch-extra_CMakeLists.txt
  head/databases/mysql57-server/files/patch-storage_myisam_mi__dynrec.c
  head/databases/mysql57-server/pkg-plist
Comment 11 Tim McCormick 2015-12-27 11:56:10 UTC
Reopening as the problem is not resolved.

The mysql-client patch has not been applied and so mysql_config is still missing.
Comment 12 commit-hook freebsd_committer 2015-12-27 13:35:46 UTC
A commit references this bug:

Author: miwi
Date: Sun Dec 27 13:34:48 UTC 2015
New revision: 404567
URL: https://svnweb.freebsd.org/changeset/ports/404567

Log:
   - Restore backwards compatibility

  PR:		205433

Changes:
  head/databases/mysql57-client/files/patch-scripts_CMakeLists.txt
  head/databases/mysql57-client/pkg-plist
Comment 13 Martin Wilke freebsd_committer 2015-12-27 13:36:26 UTC
Hi,

Sorry i forgot to commit them, its up now.
Comment 14 Mahdi Mokhtari freebsd_committer freebsd_triage 2015-12-27 13:44:40 UTC
Thanks :D