Bug 205550 - graphics/zathura: Update to 0.3.4
Summary: graphics/zathura: Update to 0.3.4
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Guido Falsi
URL:
Keywords: easy, patch, patch-ready
Depends on:
Blocks: 205551 205552 205553 205554
  Show dependency treegraph
 
Reported: 2015-12-23 19:56 UTC by Guido Falsi
Modified: 2015-12-31 14:07 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (quentin.stievenart)


Attachments
Update patch (3.32 KB, patch)
2015-12-23 19:56 UTC, Guido Falsi
madpilot: maintainer-approval? (quentin.stievenart)
Details | Diff
portlint -AC (130 bytes, text/plain)
2015-12-27 10:32 UTC, Michael Danilov
no flags Details
poudriere (63.20 KB, text/plain)
2015-12-27 10:33 UTC, Michael Danilov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Falsi freebsd_committer 2015-12-23 19:56:33 UTC
Created attachment 164562 [details]
Update patch

Hi, I'm attaching a patch to update graphics/zathura to the latest version for your approval.

Thanks.
Comment 1 quentin.stievenart 2015-12-26 09:48:41 UTC
I agree with this patch, thanks.
Comment 2 Michael Danilov 2015-12-27 10:32:31 UTC
Created attachment 164710 [details]
portlint -AC
Comment 3 Michael Danilov 2015-12-27 10:33:13 UTC
Created attachment 164711 [details]
poudriere
Comment 4 Michael Danilov 2015-12-27 10:51:33 UTC
I'm sorry, this may be irrelevant -- just want to know if anyone else here has the same problem. Will file a bug when I come up with something useful.

The command line, most noticeably in search mode, skips one character every 4..10 keystrokes. Does not affect pasting -- but it does ignore Ctrl-V or Shift-Insert in the same manner, so it must be somewhere in input handling.

The problem has been there for all my use of use zathura, which is 2-3 releases, but last time I checked, nobody on the developers' IRC was aware or had experienced this.
Comment 5 Guido Falsi freebsd_committer 2015-12-30 14:26:41 UTC
(In reply to Michael Danilov from comment #4)

Hi,

Since this problem you're experiencing isn't caused by this proposed update, so is unrelated to this "bug", could you please open a new bug report to track it?

I'm going to commit this update soon and close this bug report.

Thanks!
Comment 6 Guido Falsi freebsd_committer 2015-12-31 14:07:42 UTC
Committed! Thanks.
Comment 7 commit-hook freebsd_committer 2015-12-31 14:07:45 UTC
A commit references this bug:

Author: madpilot
Date: Thu Dec 31 14:07:26 UTC 2015
New revision: 404938
URL: https://svnweb.freebsd.org/changeset/ports/404938

Log:
  - Update to 0.3.4
  - Now requires a C11 capable compiler
  - Use make option target helpers

  PR:		205550
  Submitted by:	me
  Approved by:	quentin.stievenart at gmail.com (maintainer)

Changes:
  head/graphics/zathura/Makefile
  head/graphics/zathura/distinfo
  head/graphics/zathura/files/
  head/graphics/zathura/files/patch-zathura_main.c