Bug 205582 - libcxxrt: crash when mixing different languages with exceptions (Affects databases/tarantool)
Summary: libcxxrt: crash when mixing different languages with exceptions (Affects data...
Status: Closed DUPLICATE of bug 204786
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 10.1-RELEASE
Hardware: Any Any
: --- Affects Some People
Assignee: Rodrigo Osorio
URL:
Keywords: patch
Depends on: 201270
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-24 17:23 UTC by mejedi
Modified: 2019-03-05 14:31 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mejedi 2015-12-24 17:23:52 UTC
Unwind API was specifically designed to allow mixed language environments where exceptions from different runtimes interoperate. One particular example is C++/LuaJit combination. Due to the issues in libcxxrt, databases/tarantool crashes when linked against libcxxrt.

Upstream accepted the patch:

https://github.com/pathscale/libcxxrt/pull/32
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-09-03 19:33:14 UTC
Is this still relevant?
Comment 2 Rodrigo Osorio freebsd_committer 2019-03-05 14:31:42 UTC

*** This bug has been marked as a duplicate of bug 204786 ***