Bug 205677 - autoassign is broken
Summary: autoassign is broken
Status: Closed Not A Bug
Alias: None
Product: Services
Classification: Unclassified
Component: Bug Tracker (show other bugs)
Version: unspecified
Hardware: Any Any
: --- Affects Many People
Assignee: Kubilay Kocak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-29 01:44 UTC by Martin Wilke
Modified: 2015-12-29 02:19 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Wilke freebsd_committer 2015-12-29 01:44:57 UTC
Since a while I've notice that when a committer submit a patch it won't auto assign to him. This was already broken before the update to bz 5.X.

Example.
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=205675

It would be great if someone could fix that.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2015-12-29 02:19:03 UTC
This is not a regression, as the auto-assigner has only ever assigned issues under the following conditions:

* If Maintainer = Committer

There is an open issue (bug 200435) to add auto-assignment for other cases, such as:

* If Reporter = Committer and Maintainer != Committer

However, while it may be desirable in principle, given not all committers have commit bits to all repositories, this feature hasn't yet been implemented, as it needs to be refined and communicated to the wider project for feedback first.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2015-12-29 02:19:35 UTC
@Martin, please re-open this issue if I have misinterpreted the reported issue