Bug 205680 (multimedia/libyuv) - [NEW PORT] graphics/libyuv: YUV library for freeswitch
Summary: [NEW PORT] graphics/libyuv: YUV library for freeswitch
Status: Closed FIXED
Alias: multimedia/libyuv
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
: 204958 (view as bug list)
Depends on:
Blocks: 205681
  Show dependency treegraph
 
Reported: 2015-12-29 02:10 UTC by corsmith
Modified: 2016-03-07 08:53 UTC (History)
3 users (show)

See Also:


Attachments
svn diff of graphics/libyuv (4.46 KB, patch)
2015-12-29 02:10 UTC, corsmith
no flags Details | Diff
poudriere build log (12.13 KB, text/x-log)
2015-12-29 02:11 UTC, corsmith
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description corsmith 2015-12-29 02:10:14 UTC
Created attachment 164793 [details]
svn diff of graphics/libyuv

New port for libyuv.  It is a YUV image format manipulation library required by net/freeswitch.

Passes portlint.  Poudriere build logs attached.  Thoroughly tested for integration with net/freeswitch.
Comment 1 corsmith 2015-12-29 02:11:42 UTC
Created attachment 164794 [details]
poudriere build log
Comment 2 corsmith 2015-12-29 02:14:17 UTC
Duplicate of 204958

Although this is an earlier version of the software it is thoroughly tested with my expanded version of net/freeswitch and is the version distributed by the freeswitch team.  I was unable to build my version of net/freeswitch with numisemis version in 204958.

Please add this version instead.
Comment 3 Kurt Jaeger freebsd_committer 2016-03-06 20:49:58 UTC
*** Bug 204958 has been marked as a duplicate of this bug. ***
Comment 4 Kurt Jaeger freebsd_committer 2016-03-06 20:54:52 UTC
There are many incarnations of libyuv on github etc.

I found https://chromium.googlesource.com/libyuv/libyuv/, which is
probably the source of many of those libs. Is that the correct upstream,
if not, where is the correct upstream located ?
Comment 5 Šimun Mikecin 2016-03-07 08:40:41 UTC
AFAIK https://chromium.googlesource.com/libyuv/libyuv/ is the correct upstream.
Comment 6 commit-hook freebsd_committer 2016-03-07 08:49:54 UTC
A commit references this bug:

Author: pi
Date: Mon Mar  7 08:49:03 UTC 2016
New revision: 410509
URL: https://svnweb.freebsd.org/changeset/ports/410509

Log:
  New port: graphics/libyuv

  libyuv is an open source project that includes YUV scaling and conversion
  functionality.

  - Prepare content for compression, with point, bilinear or box filter.
  - Convert to YUV from webcam formats.
  - Convert from YUV to formats for rendering/effects.
  - Rotate by 90/180/270 degrees to adjust for mobile devices in portrait mode.
  - Optimized versions for SSE2/SSSE3/AVX2 on x86/x64,
    Neon on Arm, DSP R2 Mips are possible.

  WWW: https://chromium.googlesource.com/libyuv/libyuv/

  PR:		205680, 204958
  Submitted by:	Corey Smith <corsmith@gmail.com>, numisemis@yahoo.com

Changes:
  head/graphics/Makefile
  head/graphics/libyuv/
  head/graphics/libyuv/Makefile
  head/graphics/libyuv/distinfo
  head/graphics/libyuv/files/
  head/graphics/libyuv/files/patch-Makefile
  head/graphics/libyuv/pkg-descr
  head/graphics/libyuv/pkg-plist
Comment 7 Kurt Jaeger freebsd_committer 2016-03-07 08:53:14 UTC
Committed, thanks.