Bug 206010 - games/retroarch: Fix dependencies
Summary: games/retroarch: Fix dependencies
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords: easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2016-01-07 17:59 UTC by Yuri Victorovich
Modified: 2016-01-30 19:22 UTC (History)
2 users (show)

See Also:
yuri: maintainer-feedback+
riggs: merge-quarterly+


Attachments
patch (1.64 KB, patch)
2016-01-07 17:59 UTC, Yuri Victorovich
yuri: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2016-01-07 17:59:06 UTC
Created attachment 165223 [details]
patch

The patch fixes port dependencies.

Based on the user report that package in the official repository was crashing due to the undetected dependencies.

Poudriere build passes, and binary from the package now works as intended.
Comment 1 Yuri Victorovich freebsd_committer 2016-01-10 00:34:17 UTC
This is the bug fix, so it should be merged into quarterly.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2016-01-10 07:53:22 UTC
@Yuri:

USES=python:3 means depend on the python2 symlink via the lang/python3 port. If this port doesn't depend on that symlink, specifically, USES=python:[-]x.y[+] is the correct declaration
Comment 3 Yuri Victorovich freebsd_committer 2016-01-10 12:09:03 UTC
For some reason, this package does't can't find python with:
> PYTHON_USES=python:3.4+
error:
> Checking presence of package python3 ... no

It checks through 'pkg-config'

But with PYTHON_USES=python:3 python is found fine. Not sure why.
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2016-01-10 12:12:54 UTC
(In reply to yuri from comment #3)

It's checking explicitly and only for the python3 command. Leaving it as :3 is fine.
Comment 5 commit-hook freebsd_committer 2016-01-30 18:06:00 UTC
A commit references this bug:

Author: riggs
Date: Sat Jan 30 18:05:37 UTC 2016
New revision: 407536
URL: https://svnweb.freebsd.org/changeset/ports/407536

Log:
  Fix missing dependencies, correct USE_PYTHON

  PR:		206010
  Submitted by:	yuri@rawbw.com (maintainer)
  MFH:		2016Q1

Changes:
  head/games/retroarch/Makefile
Comment 6 commit-hook freebsd_committer 2016-01-30 19:17:13 UTC
A commit references this bug:

Author: riggs
Date: Sat Jan 30 19:16:17 UTC 2016
New revision: 407546
URL: https://svnweb.freebsd.org/changeset/ports/407546

Log:
  MFH: r407536

  Fix missing dependencies, correct USE_PYTHON

  PR:		206010
  Submitted by:	yuri@rawbw.com (maintainer)
  Approved by:	portmgr (miwi)

Changes:
_U  branches/2016Q1/
  branches/2016Q1/games/retroarch/Makefile