Bug 206060 - Mk/Uses/drupal.mk bug! sets options (comes after bsd.ports.options.mk)
Summary: Mk/Uses/drupal.mk bug! sets options (comes after bsd.ports.options.mk)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Port Management Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-09 07:57 UTC by John Marino
Modified: 2016-01-11 08:53 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Marino freebsd_committer 2016-01-09 07:57:40 UTC
With any drupal port, the new SELECTED_OPTIONS and DESELECTED_OPTIONS are broken.

> cd /usr/ports/www/drupal6-token
> make showconfig

===> The following configuration options are available for drupal6-token-6.x.1.12_1:
     DOCS=on: Build and/or install documentation
===> Use 'make config' to modify these settings

make -V SELECTED_OPTIONS -V DESELECTED_OPTIONS
(returns 2 blank rows)

The cause is because Mk/Uses/drupal.mk is manipulating the options definitions AFTER bsd.port.options.mk is included (and thus *SELECTED_OPTIONS have been evaluated)

.if ${_DRUPAL_COMP}
_USES_POST+=    drupal
PKGNAMEPREFIX=  drupal${_DRUPAL_VERSION}-
.if defined(DOC_FILES)
OPTIONS_DEFINE= DOCS
.endif

# drupal contributions must be licensed under the GPLv2 or GPLv3.  This is
# documented at: http://drupal.org/licensing/faq/
.if !defined(LICENSE)
LICENSE=        GPLv2 GPLv3
LICENSE_COMB=   dual
.endif


After speaking with bdrewery about the idea of relocating the *SELECTED_OPTIONS evaluations to bsd.port.mk, he indicated that he believed it is an error to use Mk/Uses to change options and that in his opinion, Drupal is what needs changing.

He also pointed out that drupal.mk also makes the mistake of of assigning OPTIONS_DEFINE with "=" rather than "+=" which overwrites any previous options definitions (strike two)


This PR is to request that DOCS be moved back to the individual ports and secondarily portmgr/documentation guys should specifically document that OPTIONS in Mk/Uses is verboten.
Comment 1 John Marino freebsd_committer 2016-01-09 07:58:19 UTC
Add miwi@ since he's actually listed as the maintainer of drupal.mk
Comment 2 John Marino freebsd_committer 2016-01-09 09:59:37 UTC
miwi released maintainership.

It would have been cool/nice/stand-up of him to release it *after* the bug that's been there the entire time he's been maintainer got resolved rather than before though.  Dropping it as soon as a bug is reported is lame.   

(If my assumption that he's proclaiming no intention to help resolve this is wrong, I apologize).

Now somebody else has to study up on what drupal is doing, from scratch, in order to fix this crap.
Comment 3 Martin Wilke freebsd_committer 2016-01-09 10:08:03 UTC
(In reply to John Marino from comment #2)

When you look at the commit history of drupal.mk, it was not resettet when I left FreeBSD for a year break. I do not use druapl did not use Drupal for ages. So please stop nagging on action peoples taking. 

Thank you!
Comment 4 John Marino freebsd_committer 2016-01-09 10:13:34 UTC
So?

You came back and were granted FULL committer status.

What you are saying is that you are happy making worthless and useless NO_ARCH commits and fill up our inboxes with commit spam, but real work with your name on it you want nothing to do with.

Very nice.


Like I said, I have no issue with you dropping maintainership, but look what everyone else does: They drop the port *after* it's been put back in a good status.  That is a classy move.
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2016-01-09 10:27:56 UTC
@John, this is neither the place nor the manner to air grievances, independent of the validity of your opinions. Please take this discussion off-line (off the issue tracker), and/or to an appropriate list.

Please refrain from continuing the current discussion in the issue tracker, including this comment, we are available at bugmeister@ cc portmgr@ if you would like to respond.
Comment 6 John Marino freebsd_committer 2016-01-09 10:30:03 UTC
koobs, thanks for your OPINION, but this is appropriate.  We had to establish that somebody else is fixing this.
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2016-01-09 10:45:41 UTC
(In reply to John Marino from comment #6)

My previous comment was not an opinion. It was as a member of Bugmeister, and an explicit request that you refrain from communicating with project members, contributors or the community, in the issue tracker, in the manner indicated.

As per my previous comment, I have provided you with the correct and appropriate method for escalating if you find you have cause to.

I will ask you again to please take this discussion off the issue tracker.
Comment 8 John Marino freebsd_committer 2016-01-09 10:47:39 UTC
I was done with the discussion two comments ago, but your judgement has kept it going.

I was unaware that being a bugmeister gave you censureship privileges on any bug report.  Silly me.
Comment 9 commit-hook freebsd_committer 2016-01-11 08:52:52 UTC
A commit references this bug:

Author: marino
Date: Mon Jan 11 08:51:52 UTC 2016
New revision: 405770
URL: https://svnweb.freebsd.org/changeset/ports/405770

Log:
  Remove OPTIONS_DEFINE out of Mk/Uses/drupal.mk (affects many drupal ports)

  The USES= fragments are not supposed to modify OPTIONS_* because they are
  loaded after bsd.options.mk.

  In the particular case of drupal, this resulted in SELECTED_OPTIONS and
  DESELECTED_OPTIONS being incorrect.  A second problem was that the "="
  was used for assignment rather than "?=", meaning that any port with
  USES=drupal got their options overwritten at some point (this included
  the main www/drupal6 and www/drupal7 ports).

  This commit adds OPTIONS_DEFINE=DOCS to almost every port that had set
  USES=drupal to correct the mistake of setting options in Mk/Uses.

  PR:	206060

Changes:
  head/Mk/Uses/drupal.mk
  head/www/drupal6-advanced_help/Makefile
  head/www/drupal6-cck/Makefile
  head/www/drupal6-chaos/Makefile
  head/www/drupal6-ckeditor/Makefile
  head/www/drupal6-content_access/Makefile
  head/www/drupal6-geshifilter/Makefile
  head/www/drupal6-google_analytics/Makefile
  head/www/drupal6-image/Makefile
  head/www/drupal6-imce/Makefile
  head/www/drupal6-menu_block/Makefile
  head/www/drupal6-mimedetect/Makefile
  head/www/drupal6-nice_menus/Makefile
  head/www/drupal6-nodewords/Makefile
  head/www/drupal6-page_title/Makefile
  head/www/drupal6-panels/Makefile
  head/www/drupal6-path_redirect/Makefile
  head/www/drupal6-pathauto/Makefile
  head/www/drupal6-print/Makefile
  head/www/drupal6-seo_checklist/Makefile
  head/www/drupal6-services/Makefile
  head/www/drupal6-tagadelic/Makefile
  head/www/drupal6-token/Makefile
  head/www/drupal6-views/Makefile
  head/www/drupal6-webform/Makefile
  head/www/drupal6-wysiwyg/Makefile
  head/www/drupal6-zeropoint/Makefile
  head/www/drupal7-wysiwyg/Makefile