Bug 206151 - emulators/open-vm-tools*: Doesn't honor ${SRC_BASE}
Summary: emulators/open-vm-tools*: Doesn't honor ${SRC_BASE}
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steve Wills
URL: https://github.com/yaneurabeya/freebs...
Keywords: easy, needs-qa, patch
: 215365 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-01-12 09:11 UTC by Enji Cooper
Modified: 2017-03-24 18:55 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback? (swills)
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Enji Cooper freebsd_committer 2016-01-12 09:11:04 UTC
$ (set -e; export SRC_BASE=/usr/src/svn/ ; export USE_PACKAGE_DEPENDS=yes; cd /usr/ports/emulators/open-vm-tools-nox11/; make clean; make build; sudo make install; make clean)
===>  Cleaning for glib-2.44.1_2
===>  Cleaning for open-vm-tools-nox11-1280544_12,1
===>  License LGPL21 accepted by the user
===>  Found saved configuration for open-vm-tools-nox11-1280544_12,1
===>   open-vm-tools-nox11-1280544_12,1 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by open-vm-tools-nox11-1280544_12,1 for building
===>  Extracting for open-vm-tools-nox11-1280544_12,1
=> SHA256 Checksum OK for open-vm-tools-9.4.0-1280544.tar.gz.
===>  Patching for open-vm-tools-nox11-1280544_12,1
===>  Applying FreeBSD patches for open-vm-tools-nox11-1280544_12,1
===>   open-vm-tools-nox11-1280544_12,1 depends on executable: pkgconf - found
===>   open-vm-tools-nox11-1280544_12,1 depends on shared library: libglib-2.0.so - found (/usr/local/lib/libglib-2.0.so)
===>  Configuring for open-vm-tools-nox11-1280544_12,1
configure: WARNING: unrecognized options: --disable-unity
configure: loading site script /usr/ports/Templates/config.site
checking build system type... i386-portbld-freebsd11.0
checking host system type... i386-unknown-freebsd11.0
configure: error: FreeBSD kernel tree not found. Please install the kernel sources (or provide the location using SYSDIR) or configure using --without-kernel-modules.
===>  Script "configure" failed unexpectedly.
Please report the problem to swills@FreeBSD.org [maintainer] and attach the
"/usr/ports/emulators/open-vm-tools-nox11/work/open-vm-tools-9.4.0-1280544/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/emulators/open-vm-tools-nox11
*** Error code 1

Stop.
make: stopped in /usr/ports/emulators/open-vm-tools-nox11

The patch in the following link fixes the above issue: https://github.com/yaneurabeya/freebsd-ports/commit/20b95eba75862ccb7137f73e4ed0e7a84b55ebdc.patch
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2016-01-12 09:15:29 UTC
Correctly assign to maintainer. The glob (*) in the category/portname didn't please the AutoAssigner.
Comment 2 Chris Collins 2016-11-02 03:38:52 UTC
I guess maintainer is dead, can anyone else fix this please?  Was reported several months ago.
Comment 3 Steve Wills freebsd_committer 2017-02-27 22:30:28 UTC
*** Bug 215365 has been marked as a duplicate of this bug. ***
Comment 4 Steve Wills freebsd_committer 2017-03-24 18:55:45 UTC
The port is updated now and this should be fixed.